16

I upgraded from google-chrome-stable_40.0.2214.95-1_amd64 to google-chrome-stable_41.0.2272.76-1_amd64 (automatic update on Ubuntu MATE 14.04 64 bit) and the mouse text selection stopped working and the cursor icons did not change when hovering over links in the updated browser, also got an annoying 'Enter you password to unlock login keyring' prompt when Chrome started.

To eliminate the distro from the mix I also upgraded Google Chrome on Xubuntu 14.04 64-bit from Google Chrome 39.0.2171.95-1 to 41.0.2272.76-1 and ran into the same problem.

I tried reinstalling the browser:

  sudo apt-get purge google-chrome-stable
  rm -rf ~/.config/google-chrome
  wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
  sudo dpkg -i google-chrome-stable_current_amd64.deb

But the problem still persisted so I downgraded back to the previous version, this worked, the problems dishappeared:

  sudo apt-get purge google-chrome-stable
  rm -rf ~/.config/google-chrome
  sudo dpkg -i google-chrome-stable_40.0.2214.95-1_amd64.deb

Older versions of Google Chrome can be downloaded from http://mirror.pcbeta.com/google/chrome/deb/pool/main/g/google-chrome-stable/

See also:

  • 1
    If you don't have a question as such (you have already solved it), you can add your answer (after 'the problem persisted' probably) in the box below. This site and other StackExchange uses a Question and Answer(s) format, it isn't like your usual forum. Also, it would be a good idea to temporarily go back to the version 41 and report the issue so it can be fixed. Also, a possibly more trustworthy source is here (source) – Wilf Mar 5 '15 at 22:42
  • I suppose rolling it back is a solution but I my post was an implicit "am I missing something here?" and "this may save someone else some time". I had posted the issue to Google but have not yet received a response. Yes, your source is possibly more trustworthy. – Stuart Rackham Mar 6 '15 at 4:05
  • I'm having the same issue. Stuart, could you please submit a link to the chrome issue you posted? I'd like to get updated when it's fixed. – Michael Bylstra Mar 7 '15 at 8:56
  • I submitted it from the browser menu, you don't get any link just a 'Thank you'. I've just taken a look at the Chrome forum and see the same issue reported here productforums.google.com/forum/#!searchin/chrome/… and here productforums.google.com/forum/#!topic/chrome/3Kvz9eGm87M – Stuart Rackham Mar 7 '15 at 19:06
  • 2
    Seems to be VirtualBox related, see code.google.com/p/chromium/issues/detail?id=456222 – Stuart Rackham Mar 7 '15 at 19:17
1

Have you tried the workaround?

sudo cp /usr/share/applications/google-chrome.desktop ~/google-chrome.desktop.bak~
sudo sed -i 's/\/usr\/bin\/google\-chrome\-stable/\/usr\/bin\/google\-chrome\-stable \-\-touch\-devices=123/g' /usr/share/applications/google-chrome.desktop

If this workaround causes problems, use this command to uninstall:

sudo cp ~/google-chrome.desktop.bak~ /usr/share/applications/google-chrome.desktop

Source: https://code.google.com/p/chromium/issues/detail?id=456222#c175

0

For me i had to disable hardware acceleration from chrome advanced settings. Debian jessie + mate desktop. Not sure if the --touch-devices=123 was required in my case.

-2

The very same problem which made me to shift on to firefox. It's good but google guys have fixed the problem. You can try instead the latest version available for firefox as it's far more impressive than Chrome. http://mozilla_firefox.en.downloadastro.com/

  • This URL links to an EXE file which is of no use. – Smile4ever May 20 '15 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.