8

My laptop screen goes black after I resume it from suspend while using nvidia as default graphics manager, but when I use Intel graphics as default I dont have this issue. Nothing works, even restarting lightdm is useless.

I have pm-suspend.log file here

NOTE: I can switch between Intel Intergrated graphics and NVIDIA Dedicated graphics using Nvidia-optimus drivers. NVIDIA graphics card named 820m. I am using nouveau driver v346.47(as shown below).

additional drivers -nvidia drivers - ubuntu

nvidia control panel ubuntu

  • 2
    I have the same problem: system wakes up (can hear sounds, use keyboard/mouse blindly), but screen stays off. nVidia geForce Go 7400 too, but pretty defect... my workaround is to entirely disable suspending. If interested, keep watching my active question here – Byte Commander Mar 5 '15 at 19:30
  • 1
    I hahe same problem here. visit askubuntu.com/questions/713630/… – user441517 Dec 27 '15 at 10:47
  • 1
    I have no solution, but a workaround that (almost) always works: go to another terminal (eg. type [Ctrl]+[Alt]+[F3]) and then go back to terminal nbr 7: [Ctrl]+[Alt]+[F7] – Philippe De Brouwer Feb 12 '16 at 20:30
  • I'm not sure if this is relevant but have you looked into booting with nomodeset flag? To test it: askubuntu.com/questions/38780/…. To make it permanent: askubuntu.com/questions/38780/… – Hee Jin Apr 14 '18 at 1:25
0

This is a common problem with that nouveau driver that is still relevant as of three days ago. I got bricked by a kernel update, had to switch to the nouveau driver and my pet supercomputer basically became unusable with all these exact symptoms, to the letter.

If you still haven't solved this problem, please try this once you get yourself into the text mode with one of those magic key combinations:

first check your kernel version:

uname -a

then attempt to install a package linux-headers that matches your kernel version. It may say that you're already up to date, which is good. If it tries to install, then good, let it. Something like this:

sudo apt-get install linux-headers-<your kernel version from uname>

After that, install the NVIDIA drivers:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get install nvidia-396

The latest version that I use is 396. I'm on 4.13.0-39 kernel. Your version might be different depending on what you're using.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.