I am always trying to find answers for my problems with Google, but this time I give up. I've read almost every topic on every discussion board, blog posts etc. about my problem. I've tried many tips, but nothing seems to work. I've even changed Linux distribution from Ubuntu to Mint, nothing.

I'am trying to install drivers for my hybrid graphic card. Right now I have default drivers (xserver-xorg-video-ati) but there is major problem with that. When I'm trying to open few tabs in my browser (Chromium/Firefox) everything is slowing down and I have to wait until somehow it unfreezes itself. Installing fglrx or fglrx-update crashes my system. I really don't know what to do, I don't want to go back to Windows 7.

My laptop parameters:
Lenovo Essential G500H i3-3110 4GB 1TB HD8570:

  • Intel® Core™ i3 3gen 3110M 2,4 GHz
  • AMD® Radeon HD 8570 + Intel HD Graphics 4000
  • 4 GB, DDR3, 1333 MHz

Sorry for my bad English, but it's not my native language. Please help. :)

  • Could you describe what happened when you try to install fglrx / fglrx-update? You could download the latest AMD driver from their website. – P.-H. Lin Mar 6 '15 at 3:43
  • After installing fglrx / fglrx-update and after reboot, in one instance there is only black screen/console and in the other it shows small window about low graphic mode (goo.gl/lIV6td). But when I want to "Run in low-graphic mode..." there is nothing happening and I have to use ctrl+alt+f1 to go to console. – kaavuhim Mar 6 '15 at 8:46
  • When I try to install amd-driver-installer-14.501.1003-x86.x86_64.run it shows information: "Your graphic adapter is not supported by this driver. Installation will not proceed." – kaavuhim Mar 6 '15 at 9:01

For mesa, This is the best documentation right now in the web. The quick howto is to update the drivers and kernel, the more recent the better. If possible, update the distro or use oibaf PPA. Then do this:

$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x79 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 2 outputs: 4 associated providers: 0 name:Intel
Provider 1: id: 0x53 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 0 associated providers: 0 name:radeon

$ xrandr --setprovideroffloadsink 0x53 0x79

Newer versions can also do this:

$ xrandr --setprovideroffloadsink radeon Intel

I suspect the case is important, but never tested

After this config, if you setup the DRI_PRIME=1 environment variable, new applications started on that terminal will use the AMD card instead of the intel. Without this variable, apps will use intel, so make sure your 3D apps are really using this variable. Examples:

$ DRI_PRIME=1 glxinfo | grep -i opengl
$ DRI_PRIME=1 glxgears -info

Compare with

$ DRI_PRIME=0 glxgears -info
$ glxgears -info

If you get an "empty" window, first try if this gets resolved by resizing it. If not, then it may be because you don't have "compositing" enabled. Check your window manager or install and start xcompmgr before starting the application (you can kill it after if you want). Please note that some window managers disable compositing when applications run full screen.

I use this small script, named radeon.sh:

 #!/bin/bash
 xrandr --setprovideroffloadsink radeon Intel
 xcompmgr &
 xcpid=$!
 DRI_PRIME=1 $*
 kill $xcpid

Then put it in /usr/local/bin and run radeon.sh steam or radeon.sh warsow to play using the radeon card

Have fun!

  • Also, IIRC, if you want, you can force the AMD card to be the default, change that in bios... – higuita May 7 '15 at 21:06
  • Also, DRI3 might kill the need for xcompmgr/Composing WM as it enables the secondary card to write to the primary card memory (and improve a lot the performance), but i still didn't test it – higuita Feb 16 '16 at 15:45

Install fglrx by command

apt-get update
apt-get install fglrx fglrx-amdcccle fglrx-dev

when i first installed Ubuntu 14.10 i tried installing amd drivers manually, which gave me a black screen on start up.

Simply put, AMD drivers are rubbish anyway. I had issues myself with the AMD drivers, decided I would never again go with AMD again for Linux. The performance in Windows compared to Linux is pathetic. It use to be nvidia, but they appear to have improved.

That said, your intel graphics should work just fine. Intel, out of all the companies do they best job in supporting linux.

Here is what I'd suggest to do: See if you can temporarily disable your AMD graphics (perhaps from UEFI settings/Bios?) and boot with intel enabled only. It should run out of the box with the latest versions of Ubuntu.

Other than that, there are a number of proprietary packages you can try for the AMD graphics. Pick the one that works best for you. Unfortunately, I am not a very big advocate of AMD for this very reason since it performs poorly on Linux.

As for Hybrid, it wont happen on Linux. There is bumblebee for nvidia/intel setups, but for AMD/Intel systems you just get the intel graphics.

Beyond that, we can only hope for better drivers to come from AMD.

  • Thank you for your answer. I think I could live just with Intel drivers, but the issue with freezing browsers (maybe because of flash?) is just unbearable for me. Any ideas? – kaavuhim Apr 3 '15 at 19:23
  • Both the fglrx driver and the mesa driver is able to use hybrid cards. Yes, fglrx driver have a bad history and many bugs, but AMD do fix then with time. AMD is also supporting the open source drivers, and they are improving much, so much that the new AMD fglrx drivers will also use parts of the open driver. In either case, you need the latest drivers (also for the intel!!). I have use both Intel and AMD 3D in hybrid laptops, both with fglrx and mesa and both work... but there is lacking documentation and some bugs. – higuita May 7 '15 at 20:14

Here's a simple shell command that anyone can execute in order to find out which graphics card(s) is/are present on the computer:

lspci |egrep -i 'vga|display'

I recently experienced the same issue. My computer is a Dell Inspiron 5548 laptop with hybrid graphics, I mean, it has two GPU (Graphics Processing Units): a VGA compatible controller Intel Corporation HD Graphics 5500 and a display controller AMD/ATI Topaz XT [Radeon R7 M260]. The Intel GPU saves power consumption / increases battery life, but has poor graphics performance. The AMD/ATI GPU has bigger power consumption but much better graphics performance. My computer's operating system is the 64-bit Linux XUbuntu 14.04.4 (kernel 4.2.0-35-generic). You can execute uname -r in order to find out which is your system's kernel version and uname -i in order to find out if your OS (Operating System) is 32-bit or 64-bit.

After the installation of the proprietary AMD/ATI graphics driver and system reboot, the xserver (Xorg server) crashed and didn't initialize anymore. But I insisted on the installation of the proprietary AMD/ATI driver because, if compared with the generic Xorg driver for AMD/ATI GPU devices (module amdgpu), the proprietary driver (fglrx) improves performance, also improves video acceleration support (works neat with xvba-va, which is the XvBA Video Acceleration driver), and it also lowers the temperature of your AMD/ATI GPU.

=> These are the steps I took (on the Linux shell terminal) in order to fix the issue:

  1. First, I became superuser (so I didn't have to use sudo everytime):

    sudo su
    
  2. I then ran the supercommand below, in order to remove any problematic proprietary AMD driver and its configuration files, then update and clean the repository cache:

    apt-get purge fglrx* -y && apt-get clean && apt-get update && apt-get check && apt-get dist-upgrade -y && apt-get autoremove -y
    
  3. Afterwards, I installed the most up-to-date proprietary AMD/ATI driver available on my distribution's repository (FGLRX-UPDATES), along with the AMD Catalyst Control Center (AMDCCC) and the AMD-compatible video acceleration driver (XVBA-VA):

    apt-get install fglrx-updates fglrx-updates-core fglrx-amdcccle-updates xvba-va-driver -y
    
  4. Because my system is 64-bit and the AMD/ATI team didn't configure the fglrx installer properly, I had to do a small tweak. I created a copy of /usr/lib/fglrx inside of /usr/lib64:

    cp -R /usr/lib/fglrx /usr/lib64
    
  5. Another tweak was necessary, too: I also had to edit the X configuration file /etc/X11/Xsession.d/10fglrx. I executed this:

    gedit /etc/X11/Xsession.d/10fglrx
    

    ...and then I modified the first and fourth lines in order to make'em look exactly like this:

    • First line:

    LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri:/usr/lib/x86_64-linux-gnu/dri:/usr/lib/dri

    • Fourth line:

    LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib/x86_64-linux-gnu/dri

    Notes:

    • If you don't have Gedit, you can install it with this command (I'm assuming that you've already executed sudo su before):

      apt-get install gedit -y
      
    • If the installation of fglrx didn't create /etc/X11/Xsession.d/10fglrx yet, execute telinit 6 to reboot the system. If after reboot your xserver crashes (doesn't initialize the graphics), you can become superuser (sudo su) and then use Nano instead of Gedit, in order to edit the 10fglrx file directly in the shell:

      nano /etc/X11/Xsession.d/10fglrx
      
  6. After editing /etc/X11/Xsession.d/10fglrx, reboot the system again:

    telinit 6
    
  7. If xserver is still crashing, execute sudo su again and then execute this command:

    amdconfig --initial
    
  8. If everything goes as expected, after you execute this:

    startx
    

    ...the GUI (Graphical User Interface) will load.

  9. Reboot your system and try to log in. If you are unable to log in (you selected your username and typed your password, but still the login failed), some of your home configuration files may have been "owned" by root. You need to fix ownership (owner user and owner group). This time do NOT execute sudo su (if you already did, then execute the exit command or press the Ctrl D keys in order to disconnect from the superuser mode), then run this shell supercommand:

    sudo chown -R `whoami` ~ && sudo chgrp -R `whoami` ~
    
  10. Reboot your system again. If everything goes as expected, the GUI will load and you'll be able to log into your account.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.