5

Every time I boot in to Ubuntu 14.04.02 64 Bit.I have to run unity-tweak-tool --reset-unity to reset unity to its Defaults. This has happened after I install kubuntu-desktop and logged in to GNOME session once?Meanwhile I've removed and reinstall ubuntu-desktop and unity

sudo apt-get install --reinstall unity
sudo apt-get install --reinstall ubuntu-desktop

Now if I login to Ubuntu session nothing loads?so I can only log in to GNOME Flash Back compiz session..

2
  • Could you add which version of Ubuntu you are using to your queston
    – damien
    Mar 13 '15 at 6:32
  • @damien Ubuntu 14.04 64 Bit Desktop Mar 13 '15 at 7:01
1

Create /etc/xdg/autostart/unity-reset.desktop file, either as root (login with sudo -i) or simply do sudo gedit /etc/xdg/autostart/unity-reset.desktop and put the following information there

[Desktop Entry]
Name=unity-reset
Categories=Application
Exec=sh -c 'yes "yes" | unity-tweak-tool --reset-unity'

Terminal=false
Type=Application

This way you don't have to run unity reset every time, but it will do it for you

11
  • it is not working created file as root Mar 5 '15 at 16:44
  • OK. 755 permissions meant it should have been available for all users including root, but apparently it doesn't work that way. As for creating a file as root, using sudo to open a text editor is sufficient to have whatever file you write with text editor , to be owned by root and have -rw-r--r-- permissions Mar 5 '15 at 17:35
  • OK. 755 permissions meant it should have been available for all users including root, but apparently it doesn't work that way. As for creating a file as root, using sudo to open a text editor is sufficient to have whatever file you write with text editor , to be owned by root and have -rw-r--r-- Mar 5 '15 at 17:35
  • 1
    It can't be run as executable at system start up because unity-tweak-tool --reset-unity asks for options Yes/No while executing Mar 11 '15 at 14:34
  • 2
    Sorry: yes | unity-tweak-tool --reset-unity
    – Fabby
    Mar 11 '15 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.