17

In a fresh install, I have a terminal like everyone else on the Internet, but it is a weird one for me.

Here's what my terminal looks like:

My terminal

It is missing 'user@hostname' above

Note that there's no "open in new tab" action on right click and there's no label on the tabs that show up when I "open a terminal". Also, I don't really like what the shortcut ctrl + shift + t does.

Why is this happening? Is this the expected behaviour?

  • What version of Ubuntu did you install ? This seems like an old version, or a particuliar flavor (like xubuntu, lubuntu,...) – alci Mar 5 '15 at 9:45
  • What version of terminal do you have? Run gnome-terminal --version.. – heemayl Mar 5 '15 at 10:22
  • 1
    I'm using ubuntu 14.04.2 and currently using the gnome-session-fallback. – muadzmo Mar 5 '15 at 12:13
  • here it my output gnome-terminal --version GNOME Terminal 3.12.3 – muadzmo Mar 5 '15 at 12:13
  • 1
    You have the "username@hostname" portion, see user@user-N43SM at the terminal..... – heemayl Mar 6 '15 at 3:33
27

This seems to be a newer version of GNOME Terminal update (>3.10). When you open the preferences dialog, you should see something like this:

GNOME Terminal preferences dialog

When you set the "open new terminals" setting to "Tab", the new terminal action will now open a new tab in the same window instead of opening a new window.

The old behaviour regarding tabs seems to have been changed in 3.12 and 3.14, for some reason.

Tabs are back!… Sort of.

You seem to have updated your GNOME components with a version that does not ship with Utopic, so you should expect to see it break.

5

Encounter the same issue after upgrade from 14.04 to 16.04. It took me sometime to find the "preference" window as the solution mentioned above in Ubuntu 16.04. In case some other people have the same issue, I share the way to find the preference window. You can find the preferences by: open a terminal, at the terminal right top are the hidden tabs -> terminal ->Preferences

enter image description here

0

From what i understand you want the user@hostname to be in your window title, is that correct ? For example the user bellow has dad@emachineubuntu in his window title. Is that what you wanted ? enter image description here

You can set that in Profile Preferences , under Title and Command tab

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.