13

I just got my laptop in the mail and I installed Ubuntu 14.04 LTS. It all went smooth until it booted up and I noticed my touch pad doesn’t work at all. It works perfectly on Windows and when I use a wireless mouse it works as well.

Here's my xinput:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]  
⎜   ↳ Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]  
⎜   ↳ 2.4GHz RF  KEYBOARD  AND  MOUSE               id=11   [slave  pointer  (2)]  
⎜   ↳ DLL06AB:00 06CB:78F1                          id=13   [slave  pointer  (2)]  
⎜   ↳ SynPS/2 Synaptics TouchPad                    id=15   [slave  pointer  (2)]  
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]  
    ↳ Virtual core XTEST keyboard                   id=5    [slave  keyboard (3)]  
    ↳ Power Button                                  id=6    [slave  keyboard (3)]  
    ↳ Video Bus                                     id=7    [slave  keyboard (3)]  
    ↳ Power Button                                  id=8    [slave  keyboard (3)]  
    ↳ Sleep Button                                  id=9    [slave  keyboard (3)]  
    ↳ 2.4GHz RF  KEYBOARD  AND  MOUSE               id=10   [slave  keyboard (3)]  
    ↳ Integrated_Webcam_HD                          id=12   [slave  keyboard (3)]  
    ↳ AT Translated Set 2 keyboard                  id=14   [slave  keyboard (3)]  
    ↳ Dell WMI hotkeys                              id=16   [slave  keyboard (3)]  

I would love to have my track pad working and I've done some googling and browsing of this site and nothing I've tried has worked. Any input would be great. Let me know if there’s any other information that can help remedy this. I'm pretty new to Linux. Thank you very much.

Edit: I've updated the kernel to 3.19 and checked my Additional Drivers which had nothing for me. Neither of which worked.

17

You can fix it by switching off i2c_hid and setting nopnp in boot parameters this way

  1. Run

    sudo -H gedit /etc/default/grub

    In the open window edit line

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    it should look this way

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"

    Save file and run

    sudo update-grub
  2. Run

    echo "blacklist i2c_hid" | sudo tee /etc/modprobe.d/i2c-hid.conf
    sudo depmod -a
    sudo update-initramfs -u
    echo "synaptics_i2c" | sudo tee -a /etc/modules
    
  3. Reboot.

  • I got my 3551 with 14.04, which I upgraded to 14.10. The touchpad worked fine with both. However, I upgraded to 15.04 and it stopped working. I upgraded yet again and found that it didnt work with 15.10 and kernel 4.x. The solution above fixed it for me instantly! – aalaap Aug 24 '15 at 16:08
  • You are awesome @Pilot6 – vineet Jan 5 '16 at 16:51
  • this resolved the problem for Dell Inspiron 13 7000 (7348) and Ubuntu 1510 – david.barkhuizen Jan 10 '16 at 6:00
  • Thank you very much! These commands fixed the problem. Both the touchscreen and the touchpad now work as expected. – Andrew Sklyarevsky Apr 2 '16 at 20:58
  • The touchpad on my Dell Inspiron 3558 worked fine, but I was unable to disable it using xinput disable ID (with ID found through xinput list). The above solution made everything work as desired; wonderful! – Phil Hirschhorn Dec 22 '16 at 3:43
1

Not sure if you already fixed this, but you will need to blacklist i2c-hid. So all you will need to do is open /etc/modprobe.d/blacklist.conf as super user and add 'blacklist i2c-hid' without the quotes towards the end of the file. Reboot and your touchpad will work.

source: http://trustdarkness.com/wordpress/dell-sputnik-xps-13-touchpad-settings-not-working-in-updated-ubuntumint/

0

I have the exact same laptop and I had the exact same problem but i found an easy solution. Just boot on legacy mode and touchpad is working :-)

  • 1
    Are you talking about Legacy BIOS mode? Because there are other boot options called "legacy"… – David Foerster Mar 19 '15 at 1:08
  • Welcome to Ask Ubuntu! ;-) Please edit your answer, improve it, and drop a note so that I can review my assessment of your answer, because the system flagged your answer for automatic deletion... :-( – Fabby Mar 19 '15 at 8:42
0

Try this:

from the command line, enter sudo nano /etc/apt/sources.list in this file are 2 'extra' repositories. Uncomment these and reboot so that your system can update available repo's. Select 'software & updates from the launcher once you are back up and running, go to the other software tab and enable the extra repositories. You should be prompted to authenticate at this stage. Next, go along to the additional drivers tab. You should find a driver that says something like 'meta package for Dell blah blah-insert-model-name-here from dino' click to enable this driver, then apply. Reboot, and you should have a fully functioning touchpad!

protected by Pilot6 Jan 23 '16 at 15:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.