0

Currently running 12.04LTS looking to upgrade to 14.04LTS. Received the following warning from upgrade manager before starting upgrade:

Running the 'unity' desktop environment is not fully supported by your graphics hardware. You will maybe end up in a very slow environment after the upgrade.

Followed link to suggested web site:: https://wiki.ubuntu.com/X/Bugs/UpdateManagerWarningForUnity3D

Warning is titled: "Updating a system without support for 3d to run the unity shell". It says I probably have old hardware. This is literally a brand new box, although a budget Lenovo model (H50). It has Intel Pentium G3250 (3.20GHz 1333MHz 3MB), Intel HD Graphics (on board generic Intel graphics, hardly unusual), 12GB memory. Runs 12.04 perfectly fine. Dual boot with Windows 7, which also runs fine.

Reference another Ask ubuntu question about same thing, but with no hardware specifics: Upgrade popup says my graphic hardware is not supported. Is this true?

I would think many systems these days without specialized graphics cards come with Intel graphics on the motherboard. Is this really not supported by Ubuntu?

update, I tried 14.04 by booting the CD, that worked fine. It recognized the graphics card correctly, per the system details page. Did not try installing from the CD.

update, info for command lspci -nn:

00:00.0 Host bridge [0600]: Intel Corporation Haswell DRAM Controller [8086:0c00] (rev 06)
00:01.0 PCI bridge [0604]: Intel Corporation Haswell PCI Express x16 Controller [8086:0c01] (rev 06)
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0402] (rev 06)
00:03.0 Audio device [0403]: Intel Corporation Haswell HD Audio Controller [8086:0c0c] (rev 06)
00:14.0 USB controller [0c03]: Intel Corporation Lynx Point USB xHCI Host Controller [8086:8c31] (rev 05)
00:16.0 Communication controller [0780]: Intel Corporation Lynx Point MEI Controller #1 [8086:8c3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation Lynx Point USB Enhanced Host Controller #2 [8086:8c2d] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation Lynx Point HD Audio Controller [8086:8c20] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation Lynx Point PCI Express Root Port 1 [8086:8c10] (rev d5)
00:1c.2 PCI bridge [0604]: Intel Corporation Lynx Point PCI Express Root Port 3 [8086:8c14] (rev d5)
00:1c.5 PCI bridge [0604]: Intel Corporation Lynx Point PCI Express Root Port 6 [8086:8c1a] (rev d5)
00:1d.0 USB controller [0c03]: Intel Corporation Lynx Point USB Enhanced Host Controller #1 [8086:8c26] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation Lynx Point LPC Controller [8086:8c5c] (rev 05)
00:1f.2 SATA controller [0106]: Intel Corporation Lynx Point 6-Port SATA AHCI Controller [8086:8c02] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation Lynx Point SMBus Controller [8086:8c22] (rev 05)
01:00.0 Serial Attached SCSI controller [0107]: Adaptec ASC-1405 Unified Serial HBA [9005:0450] (rev 02)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 0c)
04:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0036] (rev 01)
  • Hi, could you update your question with lspci -nn command output in your terminal(Ctrl + Alt + t)? – P.-H. Lin Mar 5 '15 at 10:01
0

This might be because Ubuntu 12.04 still had unity 2d,while later version only support unity 3d. Intel graphics are mostly used for mid-low end models. Honestly I would just back up all my data and try to install 14.04.If it fails,then 12.04 is supported all the way until 2017,and I would just reinstall it.Perhaps you could create a third partition and install 14.04 there until you are convinced it works.

  • Well, Intel graphic works just fine with 14.04 and Unity.. Think theres something else behind this issue. – aXept Mar 5 '15 at 0:31
  • From what I know,upgrades from Ubuntu Linux 12.04 to later versions did make such 'false positive error messages' – Mario Kamenjak Mar 5 '15 at 0:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.