2

My objective is to change globally the LANGUAGE var to en_US.UTF-8. Currently it is en:he:en.

When issuing command locale I get this output:

LANG=en_US
LANGUAGE=en:he:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8

I can change LANGUAGE for bash in .bashrc with export. It works afterwards for GTK programs I start from the shell.

export LANGUAGE=en_US.UTF-8

But that does not hold for programs I start from Kde menu or alt-f2.The menu of any GTK program I start from there appears in the second language instead of English.

  • I have investigated and changed /etc/default/locale but that did not help.
  • I have tried gnome-language-selector. The same result.
  • I have tried to change KDE system settings -> locale. No help.

Where does the setting LANGUAGE=en:he:en comes from ?

1

I saw that you found where to change it. However, a few things:

  • en_US.UTF-8 is not a valid value in the LANGUAGE variable. You probably just want en.
  • I noticed that LANG has the value en_US. That enables latin1 encoding, which you don't likely want. Should be en_US.UTF-8.
  • If LANG is set correctly, you should not set the LC_ALL variable, because it effectively disables all GUIs for managing languages/locales.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.