2

I have purchased a TP-LINK TL-WN781ND 150Mbps Wireless PCI Express Network Nic and running on Ubuntu latest version 14.04.2 I'm getting very slow speed.

Please see the required information about my network and devices here.

But when I am using Mac and Windows systems I am getting good speed. Only problem when comes in the Ubuntu OS. And the wireless is showing very less range when connecting in Ubuntu OS (Showing hardly one bar out of 4 bars).

My router model: Cisco Linksys E900 and is set in Network Mode: Wireless-N only

Upgrading the kernel gives: linux-generic is already the newest version.

The speed is better when using: ethtool --change eth1 speed 10 duplex half autoneg off

The speed doesn't improve beyond ethtool --change eth1 speed 100 duplex half autoneg off

  • Maybe try setting your router to legacy B/G mode? Wireless N is a little wacky. It might give stability to your connection, thus increasing the speed. BTW my Tplink 722N works great with Ubuntu and was cheap. – Chev_603 Mar 23 '15 at 20:05
  • @Fabby Here is it. I have included the commands in it paste.ubuntu.com/10693284 – user3613331 Mar 28 '15 at 5:06
0

Your network card seems to be having an auto-negotiation issue or a cabling/port problem.

As the diagnostics in the comments don't improve the speed beyond 100MBit half duplex (50Mbps), please add the following commands to your /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
post-up ethtool --change eth1 speed 100 duplex half autoneg off

and that should provide a very stable workaround to your problem as these will survive a reboot whereas the ethtool --change eth1 speed 100 duplex half autoneg off just on the command-line does not. So stable, in fact, that we can call it a "solution"... ;-)

| improve this answer | |
  • Performance has improved little bit. And I have ordered external high receiving power antenna to fix this :P Thanks for your help guys! – user3613331 Mar 28 '15 at 13:35
  • Could you tell why I am not able to see the output for following commands..... ethtool -S eth1 and ethtool -a eth1 – user3613331 Mar 28 '15 at 13:36
  • I don't use the short naming convention from the 1970s as they are hard to remember, so no, out of the top of my head I don't know... However, if you ask a new question and refer back to this question and ask what you're trying to accomplish, I'd be happy to help! ;-) >:) – Fabby Mar 28 '15 at 13:51
0

GOT the fix!!!

Since it was a signal issue I replaced my antenna 2dB to 10 dB.

Now im getting proper signal and great speed.

Thanks for the help guys on commands.

| improve this answer | |
0

I had to disable wireless N, to get it to work reliably.

To do so, add:

options ath9k 11n_disable=1

to the file (create it, if it doesn't exist):

/etc/modprobe.d/ath9k.conf

You can do this with this command in the terminal:

sudo gedit /etc/modprobe.d/ath9k.conf

and add the line at the end. Restart your computer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.