7

I was trying to follow instructions provided in this question AFAIU bcmwl-kernel-source is a proper driver for me. But after installation nothing changed. By "nothing changed" I mean iwconfig shows only eth0 and l0 with no wireless extensions, rfkill list all contains hci0: Bluetooth.

I found that bcm43xx was blacklisted in /etc/modprobe.d/blacklist.conf, after commenting this line and removing previously installed driver I repeated the same actions. The result was the same.

The line above the bcm43xx in /etc/modprobe.d/blacklist.conf file says "replaced by b43 and ssb". So I have removed previously installed driver again and edited back blacklist.conf.

I installed firmware-b43-installer, b43 was listed in the lsmod, but I am still was not be able to see any wlan in iwconfig.

Any help will be highly appreciated.

edit1

lspci -vnn | grep Network
06:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

edit2

sudo apt-get install --reinstall bcmwl-kernel-source
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/1,126 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 225024 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) over (6.30.223.141+bdcom-0ubuntu2) ...
Setting up bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) ...
Loading new bcmwl-6.30.223.141+bdcom DKMS files...
Building only for 3.16.0-31-generic
Building for architecture x86_64
Building initial module for 3.16.0-31-generic
Error! Bad return status for module build on kernel: 3.16.0-31-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/make.log for more information.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-31-generic

sudo modprobe wl
modprobe: FATAL: Module wl not found.
4
  • I've asked out resident Broadcom expert to look into this. He will wake up in about 6 hours... Please help him as much as possible by providing all the information he requests so that he can help you! ;-) – Fabby Mar 4 '15 at 8:49
  • Do you have anything listed regarding the issue under Additional Drivers? – Mitch Mar 4 '15 at 8:51
  • @Mitch I am not sure that I understood what are you talking about. How can I check that? I do not use GUI, the GRUB_CMDLINE_LINUX_DEFAULT="text nomodeset" in the /etc/default/grub – midas Mar 4 '15 at 9:11
  • Could you already please go to a terminal and type lspci&&lsusb. Then edit your question and copy-paste the output of the command into your question as preliminary data that Dr. Chili will need to operate the patient... ;-) – Fabby Mar 4 '15 at 12:29
8

AFAIU, bcmwl-kernel-source is correct, so I suggest you reinstall it:

sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

Now check the logs for informative messages:

dmesg | grep wl

It appears that, although you have a 3.16.0-xx kernel (thanks, @Jeremy31!), apt has tried to install the version for Ubuntu 14.04. I suggest you remove the version that failed to install:

sudo apt-get purge bcmwl-kernel-source

Download these packages to your desktop: http://packages.ubuntu.com/utopic/bcmwl-kernel-source and also: http://packages.ubuntu.com/utopic/dkms Be sure to get the 32- or 64-bit version as needed. Find out with:

arch

For example, if it returns x86_64, then you need the 64-bit version; known at packages.ubuntu as amd64.

Install the packages with:

cd ~/Desktop
sudo dpkg -i *.deb
sudo modprobe wl

Again, note and post any errors.

1
  • Chili, midas has 3.16 kernel – Jeremy31 Mar 4 '15 at 17:26
3

While chili555 answer worked for me, I reinstalled Ubuntu and then discovered an alternative method to the same solution. This requires an active connection to the Internet.

  • Open System Settings > Software & Updates > Additional Drivers
  • Select "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)"
  • Apply changes

Restart is required, although it worked without restarting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.