0

I am facing audio problems on kubuntu 14.04.

I have already removed the fast boot from windows 8. So, That can't be the problem.

I was trying this: https://help.ubuntu.com/community/SoundTroubleshooting

paacmd shows that the device is not muted.

Here, "aplay /usr/share/sounds/alsa/Front_Center.wav" doesnt work for the user.

Even in the admin am getting error

subodh@Arya-XPS:~$ sudo -i
root@Arya-XPS:~# sudo aplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory

Once I had tried this command to get the audio working:

rm -r ~/.config/pulse; pulseaudio -k

now it is no longer working.

So it is a configuration problem on kubuntu?

6
  • When did sound problem occur, did it work when you installed Kubuntu – Faizan Akram Dar Mar 4 '15 at 6:07
  • When i kubuntu installed it was not working. Then I read somewhere to try this : rm -r ~/.config/pulse; pulseaudio -k. this issue was also intermitent on windows. So i install the windows audio driver from dell support. After that it stopped working on kubuntu. – subodh1989 Mar 4 '15 at 6:09
  • try reinstalling pulseaudio by executing following command in terminal: sudo apt-get install --reinstall pulseaudio – Faizan Akram Dar Mar 4 '15 at 6:10
  • tried that not working – subodh1989 Mar 4 '15 at 6:17
  • please edit your question with output of command lspci -v and content of /etc/modprobe.d/alsa-base.conf – Faizan Akram Dar Mar 4 '15 at 6:44
0

First Method:

Execute following commands one by one in terminal :

sudo apt-get remove --purge alsa-base pulseaudio

sudo apt-get install alsa-base pulseaudio

sudo alsa force-reload

Restart your system and see if sound works.

Second Method:

Open the terminal and edit speech-dispatcher file by using the following command:

sudo gedit /etc/default/speech-dispatcher

and change RUN=yes to RUN=no

Restart your system and see if it works.

If none of above works, try editing alsa-base.conf by following method:

Execute following commands in terminal

sudo gedit /etc/modprobe.d/alsa-base.conf

and add this line to the file and save it, then reboot your system.

options snd-hda-intel model=auto
2
  • the first and third command doesnt work. – subodh1989 Mar 4 '15 at 16:45
  • For the second command file does not exist . I have checked in other system having kubuntu. It doesnt need that file. – subodh1989 Mar 4 '15 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.