on my 64bit installation of lubuntu (lxde) nm-applet has been working fine but since my latest installation of several updates (haven't updated for some weeks) it seems something broke and i can't seem to make use of nm-applet any more.

while i am aware that there are several questions regarding disappeared nm-applet icons (e.g. this askubuntu-question) the proposed solution of manually adding nm-applet to the lxsession-autostart-settings did not help as the icon still won't show (and seems fixed to me as there is a default entry called Ǹetwork` that i believe to have been missing before), so i've reverted that back to no manual entry.

after some more fiddling around i've found a thread (can't find the link any more, sorry) where it was proposed to:

  • remove Indicator applets from the shown/enabled Panel Applets
  • change the line Exec=nm-applet in /etc/xdg/autostart/nm-applet.desktop to Exec=dbus-launch nm-applet.

after doing so the nm-applet icon is indeed back and also does list available networks in range but when trying to connect to an encrypted wifi-network (didn't try non-encrypted) the applet acts as if its about to connect (animated icon) but then fails.

i've removed the saved network-connection and created a fresh one (making sure i got all the settings and password correct) but still none of many tried connection-apptempt succeeds.

any ideas about what i could do to diagnose the problem further or anybody else having the same issues?

  • So basically, the only issue you have at this point is with encrypted networks, right ? Otherwise , open wifi should connect fine ? Have you tried connecting not through nm-applet but rather through Network window in System and Settings ? nmcli ? Mar 4, 2015 at 14:08
  • @Serg as i am currently travelling i have very limited testing capabilities and could not test with unencrypted wifi (none around). additionally i just learned about the existence of nmcli which i'll try to figure out but for now (see my answer) this seems solved although some mystery remains to me... thanks anyway!
    – antiplex
    Mar 4, 2015 at 16:42

2 Answers 2


well, after further fiddling around with this issue i finally got everything back to work (meaning being able to connect to encrypted wifi-networks using nm-applet) but what led to the success is not entirely clear as i've tried several things some of which i am unaware of how to revert.

there seem to be four factors that (in some combination) lead to a solution for me:

  • changing the corresponding line in /etc/xdg/autostart/nm-applet.desktop to Exec=dbus-launch nm-applet as mentioned in my orig. question
  • disabling the application Network that is listed in the autostart-tab in the Default applications for LXsession dialogue (i had re-enabled this before after it did't seem to help when disabled alone earlier!) and manually adding the entry of nm-applet to autostarted applications-list instead
  • removing the plugin Indicator applets from the LXpanel (right-click on panel -> Add / Remove Panel Items)
  • i then killed the nm-applet process manually after a system-restart and started it manually via terminal. this led me to a dialogue that did never show up before asking me to setup a keyring (-> password). after doing so and further trying with running nm-applet through sudo i ended up restarting my system and afterwards i could eventually connect to wifi-networks (after entering my keyring-password).

i can't recall i've changed any settings that would require the explicit use of the password-protected keyring-storage but i'm thankful things are back to normal for me.

hope this may be of help for some folks who happen to stumble across the same issues...


I had the same problem on Lubuntu 14.04 after an upgrade. I tested parts of antiplex answer:

killall nm-applet
dbus-launch nm-applet

seemed to help. So for me it was enough to

  1. go to Preferences --> Default applications for LX Session --> Autostart,
  2. uncheck Network and
  3. add dbus-launch nm-applet

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .