Need putty to work on /dev/ttyUSB0

I know for a fact that the port (console on a switch) is 9600 8/n/1, so it should be simple.

ttyUSB0 shows up in dmesg.

So shouldn't I be able to select /dev/ttyUSB0 in putty's serial configuration and it should work.

Works fine when I'm running putty with windows. Doesn't work with Ubuntu/putty. I get no response.

This is how I started it:

putty -serial -sercfg 9600,8,n,1,N

Any suggestions?

sudo putty /dev/ttyUSB0 -serial -sercfg 9600,8,n,1,N

worked for me


I use minicom. To install minicom use command

sudo apt-get install minicom

Start minicom setup with command

xxx@yyy ~ $ sudo minicom -s

You will get setup menu

enter image description here

go to Serial port setup

enter image description here

Change Serial Device

Change Bps/Par/Bits

After changes hit Enter

Save setings

enter image description here

Go to Exit to exit from setup in minicom

You minicom is ready

enter image description here

  • I had already tried minicom and kermit. Both got no response - like putty. But I'll give minicom another try using your steps/screenshots. – Scott Mar 4 '15 at 14:04
  • @Scott were you able to solve the problem, if yes can you please tell me how – user1584253 Oct 26 '19 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.