I've recently installed the latest version of Ubuntu (64 bit), alongside my Windows 8 dual booted machine. The problem I'm having is trying to connect to my school network, the school uses a username and password system, so upon entering them the top right corner icon attempts to connect to to the network, but after some amount of time either disconnects, or tells me to enter the details again.

On another note, my computer appears to work fine wireless wise when I'm at home (Which only requires password entry and not a username to get on the network). Also, I know this problem has nothing to do with my schools internet because I'm using it at this moment, on Windows 8.

I've tried suggestions from these links, all to no avail:

Ubuntu 14.04 : My computer sees the wireless network, but won't connect to it, keeps asking for the WPA password

Constantly asked for WiFi password and CA certificate

  • Hi, can you provide some more details? run dmesg and share it's output. Mar 3, 2015 at 18:55
  • Is it something similar to this? askubuntu.com/questions/279762/… Mar 3, 2015 at 19:24
  • I'm using the working network now (the one at home, so should I still run that command and post the output?) Or does using a working network not make a difference here. Mar 3, 2015 at 23:46
  • 1
    Here is the dmesg output: pastebin.com/kAdREsU5 Mar 4, 2015 at 14:56
  • 1
    Just username and pass, and I`ve noticed some new behaviour after trying the suggestions from your link. If I restart the laptop,and boot into ubuntu the top right Icon tells me I'm connected.however,when I try to use the Internet, it loads extremely slowly. Also, if I disconnect and attempt to reconnect(hibernate,suspend or airplane mode) the same problem with the laptop not connecting to the network persists. Mar 4, 2015 at 18:51

2 Answers 2


Had a similar issue. In case it is helpful for anyone, for me it was just a matter of changing from TLS to PEAP under the network settings.


If your school has one password for wifi: Click on the intenet connectivity menu (top right corner menu with wifi signal). Click Edit connections. Find your school's network from the list and select. Click edit. Click Wi-Fi Security tab. Set securitty to WPA & WPA2 personal (assuming thats the system your school uses). Enter your password.

If it is the kind where you log onto some service, maybe try fogetting the network and re-connecting to it Click the internet connectivity menu. Click edit connections. Find your school's network from the list and select. Click delete. Wait a minute. Click internet connectivity menu. Find your school's network. Click on it and see if things start working.

  • Our school login is based on each student, so everyone password and username our different. And as for your second suggestion, I've tried that already :( Mar 3, 2015 at 18:34
  • Bummer. I got nothing then. Anyone else?
    – ohnoplus
    Mar 3, 2015 at 18:36
  • @user20842454566 This happens to me when the campus network here is over saturated and the access point fails to handle all the connections (and we have individual student logins via 802.11x) - is it possible that's what's going on? (Usually clears up for me within 30 minutes)
    – Thomas Ward
    Mar 6, 2015 at 12:33
  • Don't think so because my home wifi is having this problem as well now. And hey the school wifi works fine on windows. Mar 6, 2015 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.