I want to install ubuntu 14.04. When i press "setup ubuntu" the error "end kernel panic - not syncing: vfs: unable to mount root fs on unknown block(2,0)" is appears Even if do not do anything this error appears after some seconds. I have 3 DISKs. Two of them is NTFS, 3th one is FAT32 (another HDD). Fat32 is for Ubuntu OS.
Searched for the solutions. However answers was about typing some codes (promts) on ubuntu. Recently in my computer windows 7 is installed.


I solved this problem by changing the ubuntu setup containing usb's format from NTFS to FAT32

On Windows, go to My Computer, right click on the USB disk on which you want to add the Ubuntu set-up, then select format and a new window will open. Change file type from NTFS to FAT32 and click start.

After this process, you can continue your Ubuntu Installation with USB

  • 2
    This is almost an answer. Can you explain how you did that? Mar 3 '15 at 21:39
  • 2
    What David means is that it is an answer, but not an excellent answer. ;-) with just an additional minutes of editing time, you can make it an excellent one and leave a comment @Fabby and I'l come and upvote it! :-)
    – Fabby
    Mar 3 '15 at 22:15
  • @Fabby i did it :)
    – isifzade
    Mar 4 '15 at 13:24
  • 1
    And I improved it a bit and upvoted! ;-) Please review my edits and also review the editing help to improve the readability of your questions in the future... ;-)
    – Fabby
    Mar 4 '15 at 13:28
  • Possibly, not the change of format type but just the re-formatting itself fixed your corrupt USB media (as jerod answers points out). Dec 4 '15 at 18:21

This apparently can also happen after a bad install. The simplest thing to do is to remove your usb from the target system, format it again (via a source system) to FAT32, recreate your Live USB and then rerun install. This fixed the issue for me and installed successfully for Ubuntu 15.04

  • 1
    Same thing here! I shut down (forcingly, pressing power for a few secs), after some partitioning. I thought, the target harddisks might be in a poor state, but indeed, formatting and (Linux Live USB Creator) recreating the USB stick did the job! Dec 4 '15 at 17:59

Regarding the previous answer, I would like to share my recent experience with this same condition/error message.

I passed through it while trying to install the Ubuntu 14.04.2 LTS for Desktop from a USB media. In my case the previous message did not make any sense because my USB media was formatted with FAT32.

After a short research, reading of this version requirements I perceived that my computer did not fit the minimal amount of memory required (3 - 4 GB). As my desktop just have 2 GB of RAM, I downloaded to 32-bits version and the installation was an accomplished without further problems.

Best regards.

Murilo pugliese.

  • 1
    despite sucessful, you might have drawn the wrong conclusion: Perhaps your USB media got corrupted and re-creating the 64bit version again (as @jerod describes below) might have have enough. (Besides: it's not very likely, that gigabytes of RAM get you a kernel panic during boot... that's just too harsh) Dec 4 '15 at 18:02
  • 1
    I can confirm, that this error message might have something to do with RAM. I encountered the error message, booting 16.04 live on a somewhat ancient Acer EasyStore H341 having 4GB RAM installed. Turns out, the RAM was not fully recognized in BIOS (it showed up as 119 MB), after switching back to the old 2 GB I could boot the live disc without any problems. I had the same error from disc and via PXE boot. Apr 18 '17 at 10:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.