1

I've got the Geforce GTX460. When i want to start CUDA, i get the following error: ERROR: No NVidia compatible platform found I've testet it with every driver on the Package Manager. Always the same result.

So i've downloaded the latest driver from the nvidia page and installed it by hand. After the reboot, i've just got a black screen with a blinking cursor. So i removed the newly added driver and installed "apt-get install nvidia-current".

So im stuck at the same problem.

Some troubleshooting:

 lspci -v | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GF104 [GeForce GTX 460] (rev a1) (prog-if 00 [VGA controller])
    Kernel driver in use: nvidia
01:00.1 Audio device: NVIDIA Corporation GF104 High Definition Audio Controller (rev a1)

nvidia-settings -q NvidiaDriverVersion

ERROR: Error querying target relations


  Attribute 'NvidiaDriverVersion' (silb-PC:0.0): 331.113
  Attribute 'NvidiaDriverVersion' (silb-PC:0[gpu:0]): 331.113

cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  331.113  Mon Dec  1 21:08:13 PST 2014
GCC version:  gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) 

 dpkg -l | grep nvidia
rc  nvidia-304                                                  304.125-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA legacy binary driver - version 304.125
rc  nvidia-331                                                  331.113-0ubuntu0.0.4                                   amd64        NVIDIA binary driver - version 331.113
rc  nvidia-331-updates                                          331.113-0ubuntu0.0.4                                   amd64        NVIDIA binary driver - version 331.113
ii  nvidia-340                                                  340.76-0ubuntu1~xedgers14.04.1                         amd64        NVIDIA binary driver - version 340.76
ii  nvidia-340-dev                                              340.76-0ubuntu1~xedgers14.04.1                         amd64        NVIDIA binary Xorg driver development files
ii  nvidia-340-uvm                                              340.76-0ubuntu1~xedgers14.04.1                         amd64        NVIDIA Unified Memory kernel module
rc  nvidia-cuda-toolkit                                         5.5.22-3ubuntu1                                        amd64        NVIDIA CUDA toolkit
rc  nvidia-libopencl1-304                                       304.125-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA OpenCL Driver and ICD Loader library
rc  nvidia-libopencl1-331                                       331.113-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA OpenCL Driver and ICD Loader library
ii  nvidia-libopencl1-340                                       340.76-0ubuntu1~xedgers14.04.1                         amd64        NVIDIA OpenCL Driver and ICD Loader library
ii  nvidia-modprobe                                             340.29-0ubuntu1                                        amd64        Load the NVIDIA kernel driver and create device files
rc  nvidia-opencl-icd-304                                       304.125-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA OpenCL ICD
rc  nvidia-opencl-icd-331                                       331.113-0ubuntu0.0.4                                   amd64        NVIDIA OpenCL ICD
ii  nvidia-opencl-icd-340                                       340.76-0ubuntu1~xedgers14.04.1                         amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                                0.6.2                                                  amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             346.47-0ubuntu1~xedgers14.04.1                         amd64        Tool for configuring the NVIDIA graphics driver

Which driver should i install in order to run cuda on my machine? I know that my graphiccard supports CUDA because i was running it on windows a month or two before :)

  • you seem to be using an older driver for your video card, the current is 346.47 geforce.com/drivers/results/82251 check my tutorial here askubuntu.com/questions/66328/… more about additional drivers here askubuntu.com/questions/47506/… – JoKeR Mar 3 '15 at 8:09
  • also this be helpful askubuntu.com/questions/131506/… – JoKeR Mar 3 '15 at 8:15
  • Still no luck. I managed to boot my PC up to the login screen this time, but after i log myself in i've got no icons, no explorer, just the screen with my background image. I even can't start the terminal with ctrl + alt + T. Somehow i think my unity crashed with this driver. Is that possible? – silb Mar 3 '15 at 17:16
  • did you read my tutorial completely? did you do sudo apt-get install --reinstall ubuntu-desktop ? sometimes it may require it. And better do this from tty terminal Ctrl+Alt+1 with stopped X. – JoKeR Mar 3 '15 at 17:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.