3

I am getting an ongoing issue with Firefox 36.0 under Ubuntu 15.04.

Whenever I open Firefox it automatically sets the default language to Arabic, even though having never configured it to use Arabic:

enter image description here

When I run locale in terminal I get:

LANG=en_CA.UTF-8
LANGUAGE=en_CA:en
LC_CTYPE="en_CA.UTF-8"
LC_NUMERIC="en_CA.UTF-8"
LC_TIME="en_CA.UTF-8"
LC_COLLATE="en_CA.UTF-8"
LC_MONETARY="en_CA.UTF-8"
LC_MESSAGES="en_CA.UTF-8"
LC_PAPER="en_CA.UTF-8"
LC_NAME="en_CA.UTF-8"
LC_ADDRESS="en_CA.UTF-8"
LC_TELEPHONE="en_CA.UTF-8"
LC_MEASUREMENT="en_CA.UTF-8"
LC_IDENTIFICATION="en_CA.UTF-8"
LC_ALL=

I tried already removing completely Firefox following these steps and then re-installed again, it installed successfully using default language EN, but after some days when I open Firefox it is automatically set to default language Arabic again.

Just for safety I removed Firefox and am using only Chrome at the moment, I don't know if this is a virus or a bug related to any specific versions if there's anyone who might know I appreciate.

1

Go to Edit -> Preferences -> Contents tab and click the Choose... button to see the preferred languages. You can remove Arabic or Move Down to make it less preferred.

Content Languages

As you can see on the upper part of the window, this setting is for displaying web pages offered in more than one language. So it have nothing to do with browser language nor with any locales.

  • I understand that but what happened in my case is that I never configured or added Arabic, neither use it in any ways, I always use english as default language for Firefox but suddenly Firefox changed the default start page to Arabic with no human intervention, as from my posted image, so I suspect something related to malware in this case. – guilhebl Mar 4 '15 at 19:45
  • @guilhebl: Is Arabic included in your language preference list in Firefox? In that case, and while I have no idea why it happened, you can simply remove it. – Gunnar Hjalmarsson Mar 4 '15 at 20:48
  • I too am having this problem. My Ubuntu start page has changed itself first to Spanish, and then later to Turkish. The menu described here lists only en-us and en in my preferences. – John Apr 9 '15 at 16:33
  • I also once got the message changed to Turkish, I researched a bit and it seems to be related to adware, I was able to fix it resetting Firefox, and lately after updating both FF and Ubuntu 15.04 I stopped getting it, so I'll close this question for now. – guilhebl Apr 17 '15 at 20:27
0

I stopped getting it after updating both FF and Ubuntu, and after refreshing firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.