14

I installed Ubuntu 14.04.2 (64 bits) to my Mac OS X 10.9.5 (64 bits) using Virtual Box version 4.3.24. I am not an experienced Linux user. When I start Ubuntu, I cannot make my mouse work in the window that it operates; it disappears in the window most of the time. My keyboard works fine. I checked other questions on similar problems, but couldn't find a suitable solution. I cannot use mouse in Ubuntu (I installed it using my keyboard).

Here are the two messages that appears when I start Ubuntu; the first one relates to keyboard (mostly), the second one relates to mouse:

  1. You have the Auto capture keyboard option turned on. This will cause the Virtual Machine to automatically capture the keyboard every time the VM window is activated and make it unavailable to other applications running on your host machine: when the keyboard is captured, all keystrokes (including system ones like Alt-Tab) will be directed to the VM.

You can press the host key at any time to uncapture the keyboard and mouse (if it is captured) and return them to normal operation. The currently assigned host key is shown on the status bar at the bottom of the Virtual Machine window.

  1. The virtual machine reports that the guest OS supports mouse pointer integration. This means that you do not need to capture the mouse pointer to be able to use it in your guest OS -- all mouse actions you perform when the mouse pointer is over the Virtual Machine's display are directly sent to the guest OS. If the mouse is currently captured, it will be automatically uncaptured.

Any advices?

Solution Edit: I found one way to use mouse in the Virtual Box guest OS window. On the left above menu under the section Machine (on Mac) I clicked the button that says Disable Mouse Integration (Host key + I, Host key is left command key for me). After that I acted as if mouse integration was not available in my machine. Like stated in message 1 (in the above question) I pressed host key. I clicked capture in the box that appears. I can only use mouse in the window, when I want to use it in my host OS I need to hit the host key again. My new question is how can I make Mouse Integration really work?

16

... with an update to VBox 5.0.24 r108355 my "pointing device" setting in the "motherboard" tab changed to "USB tablet" ... I changed it back to PS/2 mouse and everything was fine again ...

host: windows 10 guest: ubuntu 14.04

4

When people search for the issue mouse integration. In the 5.0.16 version there's a input menu. And there is the button mouse integration. Slightly differently placed than before... Otherwise another solution to 'SOLVE' the problem is to do this:

sudo nano /etc/default/grub

Then add psmouse.proto=imps to the boot parameters in the line GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_CMDLINE_LINUX_DEFAULT="psmouse.proto=imps quiet nosplash"

Then hit CTRL+X to exit, then Y to save your changes. To update the setting:

sudo update-grub

And then reboot. This solution comes from this thread on Ubuntu Forums, credits: imrazor

1

Did you setup the Virtualbox config correctly when creating the VM, i.e. did you select Ubuntu (64 bit) in the following dialogue?

Virtualbox create new VM dialogue

I had the same mouse integration problem when accidentally installing Windows 10 technical preview 32 bit using the 64 bit profile. (Also, the guest OS ran painfully slow.) After reinstalling with the correct profile, it went away (already during installation, the mouse was working fine).

0

In my experience, this isn't an issue with Ubuntu as I have suffered it on non Ubuntu based operating systems in Virtualbox such as EvolveOS.

Seems to be a problem with Virtualbox v4.3.24.

My mouse will work if I transfer the USB device to the guest via Devices > USB Devices, but I have to disconnect and then reconnect the mouse to get it back from the guess.

I expect this will be solved in a newer release of Virtualbox.

Have you filed a bug?

I couldn't find this raised as a ticket at the Virtualbox site so I have raised one: https://www.virtualbox.org/ticket/13935

0

What worked for me was -

Under Machine -> Settings -> System -> Motherboard tab There's Extended Features, I had to check the box to enable I/O APIC and after that the mouse pointer was working.

protected by Community Sep 20 '17 at 15:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.