3

I am trying to install and use Xubuntu 14.04.2 on a new Intel NUC system. (Model: NUC5i5RYH, Intel Core i5-5250U, BIOS version 0137)

The installation medium is an usb flash drive and I am using the MINI-DisplayPort output.

I think the Xubuntu system doesn't recognize the graphic chip Intel HD 6000 correctly. I can only see the white mouse pointer on a blank screen. I can move the mouse pointer and can switch to the shell (CTRL+ALT+F1) but the XFCE desktop is not loading. So I can't install the system.

I tried Xubuntu 14.10 and it has the same problem. (Xubuntu 15.04 Beta is working.)

I tried:

  • xforcevesa
  • mini HDMI output
  • restart lightdm on the shell

Now I installed Xubuntu 14.04 with the mini.iso (text install). But after the installation the GUI is not 100% working. You can see it on this picture: http://www.directupload.net/file/d/3914/njdytg9x_jpg.htm

My question is: Is there any way to get Xubuntu 14.04.2 working on this device?

EDIT: I tried 'nomodeset' and I could install Xubuntu 14.04.2 (amd64). After the Installation this link (How do I set 'nomodeset' after I've already installed Ubuntu?) was useful.

  • I had the exact same problem with the NUC5i5RYH, Intel Core i5-5250U, BIOS version 0137 but was trying to install Mythbuntu 14.04.2. I also tried 15.04 which fixed the install but Mythbuntu 15.04 build does not work very well due to backend setup failures. After doing some research, I found that 14.04.3 will have the 15.04 kernel so I'm assuming this may allow us to use 14.04.3 LTS on the i5-5250U. – user392359 Mar 27 '15 at 18:30
1

Just to add to the above, I downloaded xubuntu-14.04-desktop-i386.iso tonight and managed to successfully install it on my new NUC5i5RYH with a USB thumb drive using the "nomodeset" setting in front of "quiet splash" when editing the installer options.

The menus all worked OK during the install process. However, as soon as it booted without the "nomodeset" option then it was behaving erratically, resulting in the desktop freezing or not even loading (I had set auto-login on the user account).

After attempting to boot again using the "nomodeset" option, the desktop appeared without issue, the keyboard and mouse worked perfectly.

Following the guide from https://forums.plex.tv/index.php/topic/110971-definitive-intel-nuc-how-to-guide-surround-sound-over-hdmi-apple-remote-graphics-part-2/ I managed to install the Intel Graphics drivers. However, after restarting and loading back in to the OS, strangely the desktop was only drawing/appearing when highlighting buttons or drop-down menus, otherwise was completely black all over.

Switching to the shell using CTRL+ALT+F1 as above worked OK.

  • Thanks! Maybe I misspelled nomodeset or something. I tried it again and I could install Xubuntu 14.04.2 (amd64) with 'nomodeset'. After the Installation this link (askubuntu.com/questions/38780/…) was useful. – matt Mar 3 '15 at 1:00
  • And I can confirm that the "Intel(R) Graphics Installer for Linux* 1.0.7" (01.org/linuxgraphics/downloads/2014/…) doesn't fix anything on Xubuntu 14.04.2. I think the driver is too old. After the installation I cannot use the Xubuntu installation anymore... there is only a blank screen with 'nomodeset'. Without 'nomodeset' there is only a broken graphical interface. – matt Mar 3 '15 at 3:04
0

15.04 works you need 3.18 kernel or above

Ended up going with ubuntu mate 15.04 64 bit for now. boot to live then install(don't go to install direct) kernel 3.18.0-13

Have had troubles with hard drives (mint and mate) not being detected on both 5i3 and 5i5, turns out to be the ssd power cable flexing and lifting the corner of the plug. Use a small screw driver to seat it fully when the case is almost closed.

When they are running they are great but have been a pain to get installed and up and running.

apic support seems to have a good few bugs in it, same for bios - getting message(dmsg) that your bios is broken and requested that x2apic be disabled. Also if set to performance in bios for cpu power, mate(kernel?) sets it back to normal. .

one nuc5i5ryh to rma(out of 3)doesn't even make it to the intel logo, the two i3's worked perfectly with mate 15.04 and mint17.1

0

I just upgraded my NUC DN2820FYKH to a NUC5I5RYH. I wanted Ubuntu 14.04 / 14.10.

This is what I did to make everything work :

  1. In the live CD choose the nomodeset option (F6) or just add it before the quiet splash option after typing (F8). (You will have windows bugs if you don't, and you will not be able to install Ubuntu)
  2. After installation, I upgraded to last kernel from here : http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.19-vivid/ (I read in some thread it can help)
  3. Also install the latest Intel Graphics drivers from: https://01.org/linuxgraphics/downloads/2015/intelr-graphics-installer-linux-1.0.8 . Don't forget to had the Ubuntu signature, it is well explained (it seems logical to upgrade Intel drivers).
  4. Reboot to check everything is OK, but it will still lag a lot. That is when I didn't understand why it does not suffice.
  5. As it turns out, the nomodeset option you chose when launching the live CD is persistent, and was still active in my Ubuntu installation. To deactivate it, just follow this:

    sudo nano /etc/default/grub
    

    Comment out the line with:

    GRUB_CMDLINE_LINUX="nomodeset"
    

    To comment just add a # in front of the line, to save Ctrl+O followed by Enter, to exit nano Ctrl+X.

    And update grub config:

    sudo update-grub  
    

⠀⠀6. After that reboot. nomodeset option will be deactivated and everything should be OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.