1

I recently installed Ubuntu 14.04 on my Dell XPS 15 9530.

Now, everything except the wireless connection works fine. I've googled, and found this solution, but it didn't change anything for me (i.e. I added "options iwlwifi 11n_disable=1" to "/etc/modprobe.d/iwlwifi.conf").

I'm not sure what next steps I should take to solve this problem. I've read somewhere that updating the kernel might help I ran the command "uname -r" and got "3.13.0-24-generic" back, which implies i have the kernel version 3.13 and not the newest 3.18 according to this.

If anyone has an idea what to try next or can point me somewhere, that would be awesome.

  • May we see: lspci -nn | grep 0280 Thanks. – chili555 Mar 2 '15 at 20:14
0

I would edit the file gksudo gedit /etc/modprobe.d/iwlwifi.conf and change options iwlwifi 11n_disable=1 to options iwlwifi 11n_disable=8 then save, exit, reboot This should bring back the wifi speed

You don't need to worry about kernel 3.18 as if you use the software update program, it should install the latest Ubuntu kernel and I think that is 3.13.0-46 or -47 now.

|improve this answer|||||
-1

Try to change your WiFi channel on your router..

sudo iwlist wlan0 scan | grep \(Channel

will output the most congregated channels. For more info please visit this page: http://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.