1

i have bought a new Dell inspiron 15 - 3542 that has Nvidia (GM108M [GeForce 840M]). every time i install the Nvidia driver i have a black screen at the next boot, so i need to format again ! which causes me a huge pain ! this is what i get from (sudo lshw -C video)

 *-display               
   description: VGA compatible controller
   product: Haswell-ULT Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 0b
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:60 memory:f7400000-f77fffff memory:d0000000-dfffffff     ioport:f000(size=64)


*-display UNCLAIMED
       description: 3D controller
       product: GM108M [GeForce 840M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:f7000000-f707ffff

And this is what i get when i run lspci | egrep 'VGA|3D'

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
08:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)

Any idea how to get this Nvidia card work without getting the black screen again? Please help me this is urgent !! i appreciate it !

4
  • 1
    How are you installing these drivers? Are you using apt-get or are you getting them from Nvidia's website? And what ones are you getting? – Aaron Flores Mar 2 '15 at 15:55
  • I have not installed yet any invidia driver, each time i try to install nvidia-current or any other driver i get a black screen on the next boot – kallo kallo Mar 2 '15 at 16:19
  • I also tried nvidia-340 which is compatible with GeForce 840M and again i had the black screen then i needed to format all over again, i formatted this new laptop 13 times now and still cant figure this out !! – kallo kallo Mar 2 '15 at 16:30
  • So you've tried using apt-get and ones from the website? that would've been a bit more helpful. Try nvidia-331-update-dev, that was the only one I could find to work for me – Aaron Flores Mar 2 '15 at 17:45
3

I was having the same problem, this worked for me after a lot of struggle and research, restart ubuntu and at login screen press ctrl+alt+F1 and login using your account this will take you to a terminal First, remove all the nvidia packages by:

sudo apt-get purge nvidia-*
sudo reboot

Again press ctrl+alt+F1 at login screen Then, Install nvidia packages by:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo ubuntu-drivers autoinstall
sudo reboot

Next, time you boot you will get a black screen instead of login most probably if not you are done. If you get a black screen, press ctrl+alt+F1 again and do the following:

cd /etc/X11

check whether there's a file of xorg.conf by:

ls | grep xorg.conf

It should be xorg.conf and not xorg.conf.* If not present do the following:

sudo nvidia-xconfig

Now edit the file as follows:

sudo nano xorg.conf

Under the Section Device, Identifier intel change Driver from "intel" to "modesetting" i.e: from

Driver "intel"

to

Driver "modesetting"

Now save the file and exit nano and do the following.

sudo chattr +i xorg.conf
sudo reboot

I hope this solves your problem, if there are any queries let my know. Thank You!

These links helped in the answers:

  1. Idea of changing driver to modesetting from intel

2.Modern way to install nvidia drivers

1
  • Perfect answer! Worked well for me. – iamgr007 Oct 25 '16 at 12:01
2

You have a system that likely uses the Intel hd graphics most the time to save power. This uses nvidia-prime to switch using Optimus technology. For some reason nvidia-prime would cause me problems as well, leaving me with a black screen every time unless I switch to Intel mode (when your screen is back press ctrl-alt-F1, log in, then key in:

sudo prime-select Intel

sudo service lightdm stop

sudo service lightdm start

At this point you should at least have your desktop back. What I suggest you do is install NVIDIA drivers but not nvidia-prime, or remove nvidia-prime, and install Bumblebee. This may work better for switching you graphics.

5
  • when i try what you said after installing the nvidia card i have this : Error: alternatives are not set up properly Error: intel mode can't be enabled – kallo kallo Mar 2 '15 at 16:43
  • Out of curiosity, which NVIDIA driver did you install? Was it from the official Ubuntu software center or did you get it from the xorg-edgers ppa? – cP4n Mar 2 '15 at 17:01
  • No the one from xorg-edger : nvidia-340 , as i downloaded another one from nvidia.com for GeForce 840M but i had this in the log file : Using: nvidia-installer ncurses user interface -> Detected 4 CPUs online; setting concurrency level to 4. -> License accepted. -> Installing NVIDIA driver version 346.47. -> Running distribution scripts executing: '/usr/lib/nvidia/pre-install'... -> done. -> The distribution-provided pre-install script failed! Are you sure you want to continue? (Answer: Abort installation) – kallo kallo Mar 2 '15 at 17:05
  • Npw trying the nvidia current from software center hope it works – kallo kallo Mar 2 '15 at 17:10
  • it didnt work ! – kallo kallo Mar 2 '15 at 20:14
0

Give this a shot:

First purge the drivers you have in there with:

sudo apt-get purge nvidia*

Then add the ppa for Bumblebee:

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update

Then install Bumblebee and Nvidia:

sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-346

And potentially remove prime because I read it doesn't work with Bumblebee:

sudo apt-get purge nvidia-prime

Then reboot and cross your fingers. Hopefully this works. I personally was working on these drivers for a week with my GeForce 860M trying to get it to work right.

EDIT: Use nvidia-340 if those are the drivers that the nvidia website said you should use with your card. I just used 346 because they are the latest and compatible with the 860M

6
  • Thank you so much ill give it a try and ill let you know – kallo kallo Mar 2 '15 at 17:47
  • 1
    Didnt work !! black screen again !! :-( – kallo kallo Mar 2 '15 at 19:24
  • Believe me I feel your pain. Another thing worth trying is getting your drivers from the mamarley ppa. That's where my 346 drivers are from and he has the 340 drivers as well. – cP4n Mar 2 '15 at 19:37
  • sudo add-apt-repository ppa:mamarley/nvidia sudo apt-get update sudo apt-get install nvidia-340 – cP4n Mar 2 '15 at 19:37
  • May require you removing xorg-edgers ppa though – cP4n Mar 2 '15 at 19:38
0

Certain Nvidia drivers do not work very well with certain GPU's, you have to use trial and error with apt-get to find ones that work well, this was the case for me when I had this exact problem. The one I found to work for my GTX745 was nvidia-331-update-dev, nvidia-331-update also worked, but nvidia-current and nvidia-current-update did not work for me at all, neither did most of the others.

If none of them work, go here: http://www.nvidia.com/Download/index.aspx?lang=en-us Input your computers info and it'll tell you what driver to get. Download it then follow these steps:

  1. Enter your tty command line (can be done by using ctrl+alt+f1, to go back, ctrl+alt+f7) Side note, if you're using a laptop, you might need to also use the fn key.
  2. In the command line, login, it will prompt you enter a username then password. Once your logged in, enter this sudo service lightdm stop This stops the x-server allowing you to install the downloaded nvidia drivers
  3. Navigate to the directory of the downloaded driver, then make it executable by using this chmod +x "drver.run" without the quotes. This will make it executable and able to install
  4. Next, just enter ./the nvidia driver to run it and allow it to install, it will prompt you every now and then, choose your answers based on how you want to install (I'd recommend install the 32-bit binaries when prompted if you're running 64-bit).
  5. If no major errors arise, you should be good. Let me know what happens and I'll see what I can do.
6
  • Thank you for your reply ! i tried this way, i downloaded NVIDIA-Linux-x86_64-346.47.run and did all the steps, when i start installing i start to have a message from Nvidia that i dont have the proper hardware !!! please read the output above of the lspci | egrep 'VGA|3D' command ! im tired trying to get it work ! any other suggestion ? – kallo kallo Mar 2 '15 at 19:24
  • it seems more like a hardware issue then.. before you had ubuntu, what os were you using and are you 100% sure it was working then? – Aaron Flores Mar 2 '15 at 23:24
  • This laptop comes with Ubuntu , i installed windows Nvidia works like a charm ! – kallo kallo Mar 3 '15 at 9:51
  • im contacting Dell now to get the image that was on the laptop, thats already configured for this laptop – kallo kallo Mar 3 '15 at 9:52
  • Dell ignored my request !! i dont know what to know ! – kallo kallo Mar 9 '15 at 19:07
0

You can try removing edgers ppa and getting your drivers from mamarley. My 346 drivers from there work great. Not sure what is different but the edgers 346 didn't work for me but marley's did.

sudo add-apt-repository ppa:mamarley/nvidia

sudo apt-get update

sudo apt-get install nvidia-340

4
  • Thank you for your support, ill try and let you know :-) – kallo kallo Mar 2 '15 at 20:17
  • I did ! the black screen again !! Gosh ! this is so frustrating ! Do you know how do i request a re-install ISO image from Dell ? i searched over ubuntu.com and i couldnt find it because its a pre-installed version – kallo kallo Mar 2 '15 at 20:24
  • Not sure. Although there are steps you can take to just get back to square one. I'm pretty sure if you just run that purge command to clear all the NVIDIA and reboot I think your nouveau drivers should kick back in – cP4n Mar 2 '15 at 21:40
  • Believe me i did that and it didint work ! any other idea ? – kallo kallo Mar 9 '15 at 19:08
0

Finally i could figure this out !!

the answer is here http://www.noobslab.com/2014/12/use-nvidia-graphics-drivers-in.html

Thank you all for participating !! Love you all !

1
  • 1
    Hi kallo, while this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. Please take a look here too: askubuntu.com/help/deleted-answers – bummi Mar 9 '15 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.