12

I am running Ubuntu 64-bit on VMWare workstation 10. I want to access the files on my windows 8 PC (both on same PC). I have checked "always enabled" for folder sharing on VMWare and gave path to my drives (E,F,G and a folder on my PC). Installed VM tools, they're upto date. The first two worked fine for me. But for the third one - "Error: cannot mount filesystem: No such device" is being displayed. I am not able to find the shared files in /mnt/hgfs.

sudo apt-get install open-vm-tools
sudo mkdir /mnt/hgfs
sudo mount -t vmhgfs .host:/ /mnt/hgfs

Should I enable any permission access for my drives. For the sharing properties of the drives on W8, I enabled "Share this folder" option. Even then I cannot see shared folders in my hgfs (ubuntu). I am a new bee to linux OS, so please help.

Thanks, Ramu.

4
  • Which Ubuntu is in the VM? – Thomas Ward Mar 2 '15 at 2:12
  • I am using Ubuntu 14 on VMWare workstation 10. Thanks, – Ramu Vennavelly Mar 2 '15 at 7:23
  • Which Ubuntu 14? There's two, 14.04 and 14.10. When you ask a question or answer a question regarding which version of Ubuntu you are using, include the full version number. – Thomas Ward Mar 2 '15 at 12:07
  • It's Ubuntu 14.10 (64-bit) – Ramu Vennavelly Mar 2 '15 at 17:39
24

I have a similar problem and I solved it with the procedure suggested here, as indicated in Jorge's comment:

$ git clone https://github.com/rasa/vmware-tools-patches.git
$ cd vmware-tools-patches
$ ./patched-open-vm-tools.sh

I hope this can help you.

Good luck!

9
  • Hi PieCot, Thanks a lot for the help. I have, however tried steps from here theholmesoffice.com/… , and yea the shared folders are working fine. – Ramu Vennavelly Feb 1 '16 at 20:38
  • I'm using open-vm-tools and this way works for me, thank you! – soulmachine Feb 5 '16 at 20:01
  • THANK YOU sorry for saying "thank you" I may not suppose to do that, but I just lost about 1h digging this and all answers was pure BULLSHlT be cause seems like there is no more vmware-config-tools.pl (apt-file find results nothing) and vmhgfs support (grep -i vm /proc/filesystems results nothing), but (even '16 answers) was keeping up with those, like they are there and count on it X( ... so, THIS SOLUTION ACTUALLY WORKS ... THANK YOU – THESorcerer Jun 6 '16 at 18:04
  • 1
    Please someone mark this as the correct answer. I've been battling with this problem for hours on Ubuntu 16.04 LTS. Thanks! – J Evans Jul 8 '16 at 13:40
  • works like charme without restarting the server. I agree to G Forty. It is the correct answer. – Dirk Schumacher Nov 2 '16 at 20:26
1

There is a known incompatibility between the VMware tools and the kernel in 14.10 and later. It is yet unpatched by VMware.

We have to use an alternative to VMware Tools, the open source variant, open-vm-tools. This should be patched for the issue and shared folders should then work again. First, remove the VMware tools. Then, reboot the guest, and run sudo apt-get install open-vm-tools. Reboot again. It should then have hgfs support again.

7
  • Did as suggested, but I am not able to see the shared folders. The command "vmware-hgfsclient" shows the shared folders ramu6390@ubuntu:~$ vmware-hgfsclient E F Q Hard Drive Mp3s – Ramu Vennavelly Mar 2 '15 at 23:43
  • 1
    You still have to run the mount command from the documentation (pubs.vmware.com/workstation-9/…) mount -t vmhgfs .host:/ /mnt/hgfs will work, but create the shares directory first, and run it. It should work then. – Thomas Ward Mar 2 '15 at 23:45
  • 2
    mount -t vmhgfs .host:/ /home/ramu6390/shares Error: cannot mount filesystem: No such device...This error is being displayed. I created shares folder as said. I tried "mount -t vmhgfs .host:/ /mnt/hgfs" , however the error result is the same. Thanks, – Ramu Vennavelly Mar 3 '15 at 0:02
  • Did you restart the virtual machine afterwards, and make sure that Shared Folders are enabled in the VM's settings? – Thomas Ward Mar 3 '15 at 0:12
  • Yes, everything was done as said. The same error throws up for the mount commands. – Ramu Vennavelly Mar 3 '15 at 7:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.