4

Please do not mark this as duplicate. I already studied libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed and How do I resolve unmet dependencies after adding a PPA? and tried all their suggestions. Still, I cannot install libc6:i386 and, therefore, cannot run any 32-bit apps on my newly installed Ubuntu 14.04.2 64-bit.

sudo apt-get -f install libc6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


sudo apt-get -f install libgcc1:i386
...
The following packages have unmet dependencies:
 libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not going to be installed
                PreDepends: multiarch-support:i386
E: Unable to correct problems, you have held broken packages

sudo apt-get -f install multiarch-support:i386
...
The following packages have unmet dependencies:
 multiarch-support:i386 : Depends: libc6:i386 (>= 2.13-5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages

I also tried:

sudo apt-get -f install libc6-i386
...
libc6-i386 : Depends: libc6 (= 2.19-0ubuntu6) but 2.19-0ubuntu6.5 is to be installed

By the way, what's the difference between libc6-i386 and libc6:i386?

cat /etc/apt/sources.list
  (I removed comments)
deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

cat /etc/apt/sources.list.d/*
  nothing

So, simple question: how to run 32-bit apps on Ubuntu 14.04.2 64-bit?

2
  • If you still face this problem, edit the question and add output of apt-cache libc6 libgcc1 multiarch-support libc6-i386 libc6:i386 libgcc1:i386 multiarch-support:i386 in addition to apt-get -s -o Debug::pkgProblemResolver=yes install libc6:i386
    – user.dz
    Nov 22, 2016 at 9:38
  • 2
    Excuse me, 1st command was wrong here the correct one: apt-cache policy libc6 libgcc1 multiarch-support libc6-i386 libc6:i386 libgcc1:i386 multiarch-support:i386
    – user.dz
    Dec 21, 2016 at 11:02

1 Answer 1

-1

I had this same issue and after searching the internet over and over nothing seemed to work. Then I noticed the version's being referenced and that the the numbers were off for the version of Ubuntu 2.4.X installed but required 2.6.11??! Pretty fishy!!! So on a very wild shot in the dark and feeling like it was this or a re install I downloaded the latest kernel set and installed it ...POOF issue gone!. I am including a link to the kernel repo. make sure you grab all 3 files of whatever your going with (Master Header, Headers, and image..master header will be the top file in the group). Put all three in there own folder and run a batch dpkg install from the folder. That way the packages are installed in the proper order. Reboot right after, oh and dont get scared and start reading about the patch files... That is only if you are going to compile your own kernel. Not a complicated process like some will have you think. Kernel Repository

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.