9

I have 2nd gen Intel i7 laptop. I use Thermald and tlp for managing battery life (they are great!). However, sometimes I don't care about noise and power consumption, and want the CPU to run at full 3.5GHz. For some reason, this seems impossible to achieve. The fan never runs full speed, and the processor is always throttled down. When I use cpufreq-info I never see more than 2.8GHz (so turbo boost does not work), and the frequency drops down to 800Mhz when the fan starts getting "loud". This is with intel p-state and performance governor. Powersafe governor is even "worse", but that's good as it increases battery life.

Any ideas how to enable "full power"?

Thank you!

  • i added sudo update-grub to the instructions – mchid Mar 1 '15 at 21:46
  • I have seen several very similar threads / questions. While I have no proof, I think something is wrong with Thermald / intel_pstate interaction. As a test, you should try the acpi_cpufreq driver (GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable" in /etc/default/grub) and / or disabling thermald. – Doug Smythies Mar 1 '15 at 21:48
  • also you have to enable turbo boost in /etc/default/tlp – mchid Mar 1 '15 at 21:57
  • @mchid: I only meant as a test. Something is wrong somehow and I'd sure like to figure out what. – Doug Smythies Mar 1 '15 at 22:00
  • 1
    @mchid: That is not true, and the article is obsolete. intel_pstate powersave is the same or better than acpi-cpufreq ondemand; intel-pstate performance = same as acpi-performance. However, I'm not sure what changes get backported to previous kernels. – Doug Smythies Mar 1 '15 at 22:20
9

Yes, all you have to do is:

first, set tlp "governer" to performance for both ac and batt in your /etc/default/tlp file and while you are there, go ahead and enable turbo boost as well

then, edit /etc/default/grub and insert

intel_pstate=disable

after

GRUB_CMDLINE_LINUX_DEFAULT=

like this example

GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable quiet splash"

execute this command to apply the change to grub

sudo update-grub

then, install indicator-cpufreq

sudo apt-get update
sudo apt-get install indicator-cpufreq

reboot for your changes to take effect.

After you reboot, you will see an icon on your unity panel, click on this icon and you can set the cpu to performance (full), ondemand (only when needed), powersave, or conservative.


Disabling pstate may not be necessary, you can try it on and off to see if there is a difference. Make sure to update grub after making that change.

Also, indicator-cpufreq will not allow changes with pstate on (only with pstate disabled), you will still have to do that manually.

Finally, you can get better numbers from i7z:

sudo apt-get install i7z

and then, run

sudo i7z

Install lm-sensors and run sensors detect:

sudo apt-get install lm-sensors

sudo sensors-detect

Follow the prompts and select yes to everything.


finally, these links may help:

http://www.webupd8.org/2013/09/adobe-flash-player-hardware.html

Not only does this allow hardware acceleration for flash but installs VDPAU and i965

http://www.webupd8.org/2014/01/enable-hardware-acceleration-in-chrome.html

and these more recent benchmarks show a slight advantage from disabling pstate and using performance

http://www.phoronix.com/scan.php?page=article&item=intel_5960x_pstate&num=2

| improve this answer | |
  • Thanks for i7z, it is a better way to monitor cpu freq! I have enabled turbo through TLP, disabled p-state, used performance governor (through TLP), but the CPU is still "afraid" to spin up the fans. It's almost like there is a temperature limit somewhere. In windows, if I enable full performance, my laptop goes easily to 90C per core. – matus201 Mar 1 '15 at 23:48
  • @matus201 using performance through tlp does not set the freq to performance, it allows performance. If you want to set performance, you need to use some other method such as sudo cpupower frequency-set -g performance or disable pstate and use indicator-cpufreq to set it to performance. – mchid Mar 2 '15 at 0:12
  • @matus201 as suggested you could try disabling thermald as a test but I wouldn't recommend it. Just because the cpu gets hot doesn't mean you are actually getting any more performance from it. – mchid Mar 2 '15 at 0:15
  • I used the cpupower to set governor to performance, and it seems to work in the sense that the governor is performance. CPU frequency jumps to 3.5GHz when I task the system; however, as soon as the fans spin a little bit up (on vaio fans are controlled by bios), CPU is throttled to 800MHz. When they quiet down, frequency jumps back to 3.5GHz, fans spin up, throttling happens and so on... This makes watching simple 720p youtube video impossible without dropped frames. – matus201 Mar 2 '15 at 4:34
  • I should mention that this jumpy throttling happens with or without p-state (de-/activated through grub). It makes me think this is a special case with VAIO laptops.. – matus201 Mar 2 '15 at 4:40
1

I managed to figure this out. As usually, Sony decided to do things their way and so this is specific to Vaio laptops only.

To set full performance, you need to type in terminal:

echo performance | sudo tee /sys/devices/platform/sony-laptop/thermal_control

This sets your laptop to performance mode, and no throttling happens.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.