0
  • I installed Ubuntu on my EasyNote-TM86 today.
  • I can't access any websites although I am connected to my router.
  • Other devices (including my laptop before I installed Ubuntu) are able to establish a connection/load websites.
  • Security is WPA/WPA2
1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – fossfreedom
    Commented Mar 3, 2015 at 8:57

3 Answers 3

1

From a search sudo dpkg-reconfigure resolvconf should make /etc/resolv.conf but mine only contains nameserver 127.0.1.1

5
  • I did this, reconfigured something and restartet but Firefox is still unable to connect.
    – user383818
    Commented Mar 2, 2015 at 20:55
  • Are you using Network Manager or WICD, as Network Manager usually causes the file to be made
    – Jeremy31
    Commented Mar 2, 2015 at 23:19
  • I didn't changed the default settings/programms until now so NetworkManager I think.
    – user383818
    Commented Mar 2, 2015 at 23:32
  • I am starting to think your MAC address might be blocked on the router from other comments as you should be able to ping 8.8.8.8
    – Jeremy31
    Commented Mar 2, 2015 at 23:41
  • Solved the issue with Elementary OS connecting to my router but no to internet - thanks a million
    – Inigo EC
    Commented Nov 5, 2017 at 10:13
0

Couple of things to do:

Restart network manager

Network manager on my machine is weird. The indicator may show the machine is connected but i cannot ping anything, mostly after startup. What solves it is sudo service network-manager restart

Delete system-connections

Network manager stores config for every connection in /etc/NetworkManager/system-connections/ directory. I've noticed that for many users here on askubuntu it has been sufficient to delete every file in that folder and try reconnecting to their network.

Remove needless stuff from resolv.conf

1    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) 
2        #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN 

3        nameserver 8.8.8.8 | sudo tee -a /etc/resolv/conf.d/head 
4        printtf nnameserver 
5        nameserver 8.8.8.8 | sudo tee -a /etc/resolvconf/resolv.conf.d/head

This is your resolv.conf file as you posted. Remove lines sudo tee from both /etc/resolv/conf.d/head and /etc/resolv.conf.d/base, as well as the printf line

Your base and head files should only contain nameserver 8.8.8.8 line.

Try deleting /run/resolvconf/resolv.conf

/etc/resolv.conf file is actually symbolic link to /run/resolvconf/resolv.conf file. Delete that actual file, edit head and base files, reboot.

Try adding other DNS in nm-connection-editor

Open nm-connection-editor, either in command line, or under network-indicator drop down menu (Edit Connections). Find your desired network. Select Edit. Under IPv4 settings, select "Automatic (DHCP) Address Only", then add 208.67.220.220 on the "Additional DNS Servers" line

For more info on the subject, refer to my question and answer here. Let me know if this answer was helpful or whether the problem persists

0

My internet connection got lost after I upgraded from Ubuntu 16.04 to 18.04. After troubleshooting, I found /etc/resolv.conf empty

I also checked the file /etc/resolvconf/resolv.conf.d/tail and found it empty.

I added the line nameserver 8.8.8.8

Everything resolved.

You must log in to answer this question.