2

I just bought a dell Inspiron 300 (http://www.dell.com/us/p/inspiron-11-3137/pd)

The strange thing is that I tried with elementary Freya beta 2 (elementaryos-unstable-amd64.20150208.iso) and it correctly detects it as:

$ lshw
...
*-network
    description: Wireless interface
    product: BCM43142 802.11b/g/n
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:01:00.0
    logical name: wlan0
    version: 01
    serial: 9c:ad:97:d6:fa:1b
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless

Elementary freya is suppossed to be based on Ubuntu 14.04, and I tried with Ubuntu 14.04.02, 14.10 and also a 15.04 beta but the wireless network just won't show up.

Any idea

1
  • Please remove the lshw output and rather add the output of sudo lshw -c network instead, this will give the module and some other important info. – heemayl Mar 1 '15 at 19:48
5

If you go into system settings, software and updates, additional drivers should show the broadcom sta driver(aka bcmwl-kernel-source). This driver should work for your wifi

0

In this forum it says that the wifi wont work on live mode, but once installed it works out of the box

http://ubuntuforums.org/showthread.php?t=2244361&p=13193735#post13193735

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.