0

I am using a DSL network connection in my Ubuntu 14.04. There has been set up a primary DNS address of my ISP by default. But I want to use Google Public DNS. I tried to edit the connection by going to Edit Connections->Then Choose my DSL connection->IPv4 Settings->Method:Automatic (PPPoE)->Additional DNS Servers: 8.8.8.8 and saved. After that I checked Connection Information and found that my Primary DNS is same as before and in the Secondary DNS field there is 8.8.8.8. That means my Primary DNS has not changed and my connection is not using the DNS.

So how do I do it?

Thanks in advance.

0

You should select the option

Automatic (PPPoE) - addresses only

instead of Automatic (PPPoE). The box will then become just DNS Servers instead of Additional DNS Servers.


nm-connection-editor:PPPoE

| improve this answer | |
  • Thank you. I changed as you said. But it seems that my DNS cant resolve the connection. – Abdullah Al Imran Mar 1 '15 at 16:38
  • @AbdullahAlImran IMHO you should post that as a new question (something like "PPPoE name resolution fails after changing primary DNS server"), linking to this one and giving as much information as you can about the exact symptoms (e.g. can you ping the chosen DNS server 8.8.8.8? what does dig google.com say?) – steeldriver Mar 1 '15 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.