0

okay im using kde nm connection editor for the trick yesterday it worked but today after i booted up and started it it ran well but when i try to connect to it from my device the thing i see is connecting... and then the signal becomes a dot and about a half a second later it goes totaly underground and says unavailable untill i rescan for networks then it shows up with full signal and i totaly dont know what to do now since i need internet to my device plus when it worked yesterday it was like 5 seconds internet and then no internet until i reconect how do i fix that i have no idea what to do now i tryed reconfiguring the ap multiple times but no success my wireless card is broadcom 43XX (i dont remember)reinstalled the nonfree driver package but nothing happened HALP!!! D;

1

To set up a simple wifi hotpsot for Android and other phones using ap-hotspot as detailed here.

Basically, install it:

sudo add-apt-repository ppa:nilarimogard/webupd8

Press Enter to confirm this - then run these to actually install it:

sudo apt-get update
sudo apt-get install ap-hotspot

Use ppa's at your own risk
Start it with:

sudo ap-hotspot start

You can also stop it:

sudo ap-hotspot stop

and configure it:

sudo ap-hotspot configure

Additional info for Ubuntu 14.04:

Note this may present a security risk due to using a outdated package - also that since that was written the update hostapd in 14.04 may work, so only try this if the above does not work.

Ubuntu 14.04 apparently needs a special fix as well (bear in mind it does not have the security fixes of the newer versions).

the hostapd version in Ubuntu 14.04 is buggy and doesn't work properly. To get AP-Hotspot to work with hostapd in Ubuntu 14.04, you need to downgrade hostapd and use apt to hold the package so it's not upgraded (thanks to spupuz for the tip!). To do this, use the following commands:

64bit:

cd /tmp
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_amd64.deb
sudo dpkg -i hostapd*.deb
sudo apt-mark hold hostapd

32bit:

cd /tmp
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_i386.deb
sudo dpkg -i hostapd*.deb
sudo apt-mark hold hostapd
  • Well the ap is not detected by the hone im using an ol' Xperia Go (YEAhhhh 2012 style) just installed the things and configured the ap hotspot and ran it it didnt showed any errors it just doesen't work out of the box i need help once again ps i marked this since its the onlyest answer – Anton Fawkes May 31 '15 at 21:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.