2

Ctrl+Alt+pretty much everything else works. Ctrl+Space works. Alt+Space works. But nothing seems to see Ctrl+Alt+Space.

If I go into System Settings->Keyboard->Shortcuts and try to assign C-A-S to a shortcut, hitting the chord doesn't seem to do anything (that is, the shortcut isn't assigned), but hitting Alt+Space does.

Emacs also doesn't seem to ever receive the key, which is the real problem since Ctrl-Alt-Space is kind of important for certain programming languages. Plan B, in Emacs at least, is the key sequence ESC Ctrl+Space.

I just noticed: Ctrl+Super+Space also doesn't seem to be passed to applications, again, including the keyboard shortcuts app in the System Settings.

0

Unity maps Ctrl+Alt+S to Windows > Toggle Shaded State, whatever that is. If you disable this shortcut, then its passed to whatever application is in that window, including emacs. It is quite confusing though.

1
  • 1
    Thanks for the suggestion, but Toggle Shaded State is disabled according to my keyboard settings, and it's still not working. – David Fiander Sep 25 '15 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.