111

How do I display the menu bar of VirtualBox?

Functions like cdrom, usb, etc need access to the menu bars to work.

enter image description here

  • RIGHT CLICK MOUSE + HOME? Not working!!! Please help, what is Host and Right Control? What I should press to access the menu? – user269776 Apr 17 '14 at 5:48
  • If the answer doesn't work, you may be using the keyboard in French mode ;) – Harvinder Jun 8 '14 at 15:15
  • This may be a New Change. Unsure on that one. However you can simply double click the top of the window(where the file/menu should be) and toggle modes. – BlueToeCheese Sep 26 '18 at 21:57
162

Because you're in scale mode which causes it to be hidden.

Host + C is the toggle for scale mode (where Host is Right Control by default)

  • 6
    Lost my temper on this, lol. hours later, gave up and googled this. Thank you so much. – motobói Dec 2 '14 at 16:00
  • 3
    Amended this answer with the Host+Home trick from Steve Saporta's answer - however note that it isn't necessary to exit scale mode to access the menus in this way. – Tom May 8 '15 at 18:10
  • I'd love to understand the logic behind this behaviour. It's something so trivial, I didn't even think of Googling about it. And I lost an entire day on it. – aalaap Jul 6 '16 at 12:31
  • Thanks, that did the trick. I agree, it is a very bad behaviour without any visual hint. I thought they just decided to remove the menu. It has been frustrating me for a long time, I had to use USB filters and re-connect to pass USB device into a VM until I lost patience and searched this problem. We should consider creating a bug report upstream. – k3a Jun 6 '18 at 18:51
34

On Windows XP and Windows 7, as of Aug 2014, there's more to the story. To bring up the menu, and to be able to access all items on the menu:

  1. If you're in scale mode, disable that with Host+c.
  2. Bring up the menu by pressing Host+Home.
  3. That will display the first of several menus. To get to additional menus, press the right arrow key.
  • or just use the mouse to bring up the menu (assuming you're not in full screen mode) :) – rogerdpack Dec 30 '14 at 18:19
  • 1
    This is a great answer! I am running in FWVM and therefore have no menu bar. As far as I can tell, this is the only way to do it in FWVM. – Sanjay Manohar Feb 15 '16 at 17:50
  • 2
    Host+Home brings up the menu without exiting scaled mode – phuclv Dec 6 '16 at 10:23
5

I faced the same issue on my macbook pro and I found a solution:

A dirty workaround if using Ubuntu is to shut down all VirtualBox, and then edit the ~/.VirtualBox/VirtualBox.xml file. Find the line

<ExtraDataItem name="GUI/Toolbar" value="false"/>

and change the value to true.

If any process were still running when edited the file, the changes will most likely be gone once the processes update the file.

(Source)

In case you don't find this line (like in my case) simply add this line.

On OS X you can find VirtualBox.xml in /Users/<username>/Library/VirtualBox dir.

  • Most complete answer if you're looking for virtualboxmanager GUI toolbar(s) -- especially with the Source cited. Read the source: there's a quick way to right click the /bottom/ menu and turn on the toolbar if you haven't whacked both of them. – fbicknel Feb 27 '17 at 15:24
  • 1
    This is the only answer that worked for me. Turn off the menu bar in the gui when the VM is running and you can't turn it back on without powering down the VM and either editing the .vbox file by hand or ticking the easy to miss, untitled check box on the gui somewhere. Terrible UI. – user12753 Sep 21 '17 at 8:45
2

I was tearing out my hair until I noticed that Ubuntu 16.04 puts menus not on the window but at the top of the screen (status?) bar. I didn't have the window maximized because I did not want to see excess white space, so the window has a bar also and that is where I was looking. :) noob moment of the day for sure.

1

I came here to find an solution and suddenly had the hunch that something was interfering with the guest window processing host keys. I turned out that I enabled the "Show postion of pointer when the Control key is pressed" checkbox. Disabling it fixed the problem and now I can switch from scale mode to full screen and seamless mode. Also have the mini menu back :)

1

To return ownership of keyboard and mouse to your host operating system, VirtualBox reserves a special key on your keyboard for itself: the "host key". By default, this is the right Control key on your keyboard; on a Mac host, the default host key is the left Command key.

1

Sooo... First use "Host"+"Home" buttons, next go to "view" --> "Full screen mode" --> now you are in the full screen mode and you have to escape from full screen mode and you will see the top menu bar. :)

1

Wierd.. but you want to also make sure the menu has the proper options selected. so by..

  1. going back to the Oracle VM VirtualBox Manager,
  2. right click your virtual machine, go to setting
  3. then go down to user interface .
  4. make sure all your menu options are highlighted blue. make sure thje options look like this
  5. hit apply and/or ok (cant remember which one)
  6. go back to your virtual machine, press ctrl + hoome
  7. use the arrow keys to go down to view then select show menu bar.

solved.

do note.. if u dont see the menu after pressing ctrl + home. try pressing ctrl + c then ctrl + home.

0

CTRL+C or CTRL+F won't work if the machine is paused.

You have to press CTRL+P to unpause, if the menu is hidden.

  • CTRL + C or F will work thereafter. – ihaveitnow Jun 8 '17 at 14:07

protected by Community Sep 27 '18 at 14:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.