1

I'm trying to do Secure MySQL Replication on my VPS with Ubuntu 14.04. I follow these steps (read only Step 1: Setup SSH Tunneling): https://www.digitalocean.com/community/tutorials/how-to-secure-mysql-replication-using-ssh-on-a-vps

The problem occurs when I try to create the tunnel on my Slave machine, when I run:

ssh -L 33061:localhost:3306 tunneluser@1.1.1.1 -f -N

I get this respone:

This account is currently not available.

I did some tests, for example if I don't execute this line:

usermod -s /usr/sbin/nologin tunneluser

it create the tunnel but it throws a message "–N: not found". If i try to connect from Slave to Master whit

ssh 'tunneluser@1.1.1.1' //before to usermod -s /sbin/nologin tunneluser

it works, so my keys are correct.

First time when I tried this it had been working fine, but now I can't reproduce it againg. I'm using the same images of my VPS's, I follow same steps, there is no difference in the environmnet, what cloud be the problem?

1

I found my mistake.
The problem was in MS Word, I saved all commands in a doc file and just copy and paste them. MS Word does regular - in longer – in some cases. So, this longer dash break my last command:

ssh -L 33061:localhost:3306 tunneluser@1.1.1.1 -f -N

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.