1

I'm using the English (US international with dead keys) keyboard layout and no other layout has been set up.
My problem is that my computer turns the dead keys off seemingly random at boot. To fix this I have to set up another keyboard layout and then switch back to the English (US international with dead keys).

This is quite annoying and I'm hoping someone can shed some light onto the randomness that is my keyboard layout.

I'm using Ubuntu 14.04 with Gnome-shell version 3.10.4 and Gnome desktop (Gnome-session) version 3.9.90

  • I have been experiencing the same situation, even though this is the only keyboard I have installed, randomly at boot it works, and it doesn't. It is so so annoying – thebugfinder Mar 5 '15 at 4:51
0

I have been looking into this for like one hour, because it has been nuisance for me as well.

EASY SOLUTION

The simplest solution I found, but I am not too sure if this is working all the time but it's worth the try as the first solution is when you login in, at the right top corner, you will be able to choose your keyboard, Choose the one you want from the list, after that, next time it will be the remembered (I'm not quiet sure how this works out with multiple users who choose different keyboard layouts).

ALTERNATIVE SOLUTION

Just use it if the Easy Solution did not work. The other solution that i found is to override gnome-setting with the default system settings,

run this until you get the desired keyboard layout

$ gsettings set org.gnome.settings-daemon.plugins.keyboard active

and setxkbmap will tell you those settings

$ setxkbmap -query

and you will get something like:

rules:      evdev
model:      pc105
layout:     us
variant:    intl
options:    lv3:ralt_switch

So just add the new two following commands to be executed when ubuntu starts up, by adding the them /etc/rc.local

Command #1:

# prevent gnome from resetting keyboard setting in X
gsettings set org.gnome.settings-daemon.plugins.keyboard active false

Command #2: (based on the information obtained above by setxkbmap -query

setxkbmap -rules evdev -model pc105 -layout us -variant intl -option lv3 -option lv3:ralt_switch

Sources:

  • Thanks, I'll try it out tomorrow and let you know if it worked – Akisame Mar 10 '15 at 15:21
  • There was no need for the second command. setting 'gsettings set org.gnome.settings-daemon.plugins.keyboard active false' and then setting it back to active works every time (tried 20 reboots). Thanks for the help. – Akisame Mar 12 '15 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.