3

I have tried other solutions posted on this forum but nothing seems to work. Right now I am wired to the Internet. Please help.

Edit:

i) Command: lsb_release -a
Output:

Distributor ID: Ubuntu
Description:    Ubuntu 12.04 LTS
Release:    12.04
Codename:   precise

ii) Command: lspci -nn | grep 0280
Output:

04:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

iii) Command: sudo iwconfig Output:

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"welcome123"
Mode:Managed Frequency:2.462 GHz Access Point: 40:4A:03:BF:9A:01
Bit Rate=54 Mb/s Tx-Power=16 dBm
Retry long limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:on Link Quality=70/70 Signal level=-28 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:1 Invalid misc:58 Missed beacon:0>

eth0 no wireless extensions.

iv) I tried connecting wifi to internet and it shows that I am connected. However, I am not able to access internet. So, basically my wifi is connected but internet is not working.

v) I tried 4-5 solutions posted here, none of them seems to work. I am new to Ubuntu so not really confident as to what exactly I did. But here are some links to posts I tried:

-- http://ubuntuforums.org/showthread.php?t=2218513 -- http://ubuntuforums.org/showthread.php?t=2218513 -- there was a solution posted by some user names chilli55 that I tried but am not able to find it again right now.

  • Please edit your question and include i) your version of Ubuntu; ii) your network card model and the driver you are using (run ` lspci -nn | grep 0280) iii) the output of sudo iwconfig` iv) explain your symptoms exactly. How does it connect? What do you try that fails? v) what are the solutions you tried? How did they fail? – terdon Feb 27 '15 at 14:06
  • hey terdon, I have updated question as you said. – t-bone Feb 27 '15 at 14:21
  • Thanks for the update! That's much better. OK, how are you trying to access the internet? Do you mean that you can't see webpages? What's the output of ping google.com? It looks like everything is fine, can any other device connect to the internet wirelessly? Are you sure your router is set up correctly? – terdon Feb 27 '15 at 14:24
  • yes. My laptop is dual boot, internet works fine on Windows, which I have been using for the past couple of months. Tried connecting Ubuntu today and internet doesn't work. Yes, webpages don't load but wifi shows connected to the internet. Right now, I am wired with my ethernet cable. – t-bone Feb 27 '15 at 14:26
  • Well, you don't have an IP. Have you set up your wireless connection to get an IP automatically (DHCP)? Do you have a DHCP service running on your router? Perhaps you have set up Windows with a static IP and that's why it works. – terdon Feb 27 '15 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.