I have a brand new Dell XPS 15. I dual boot it with Windows 8.1 and Ubuntu 14.10 The Wireless Network Adapter is Broadcom BCM4352 802.11ac with PCID [14e4:43b1] (rev 03).

The 4352 is not included in the list for installation via bcmwl-kernal-source file. I tried this anyway, but the Terminal command led to the file starting to install, but then stopping. Sometimes I get a permission denied error message.

As a result of reading and trying all advice from forums I have decided to completely reinstall Ubuntu 14.10. I doubt my particular Broadcom Wireless Card has no support on Ubuntu 14.10?


The advice of Chili555 worked. I now have working wifi using Broadcom Wireless Adapter BCM4352 802.11ac PCID [14e4:43b1] (rev 03)

4 Answers 4


The 14e4:43b1 device isn't yet included on the many guides because we're not quite sure how to get it working yet. We are happy you've volunteered to help us!

The most likely driver is bcmwl-kernel-source. Let's try again:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source
sudo modprobe wl

If you haven't any other network connection available, you may follow this process to get the files from the install USB: Unable to connect to any Wifi in Ubuntu 14.04

  • 1
    Just wanted to confirm that I have a Lenovo y50-70 using Broadcom BCM4352, 14e4:43b1 (rev 03) and this driver worked. Thanks!
    – wmjbyatt
    Apr 3, 2015 at 17:13
  • I also have Lenovo y50 with BCM4352 802.11ac and this driver worked. Many thanks!
    – Stev
    Jun 16, 2015 at 14:23
  • This worked for me to get wifi working on a Dell Precision M3800. Thanks :)
    – juckele
    Mar 15, 2016 at 17:21
  • This also worked for the Asus G750J. Thx :)
    – Marco
    Feb 6, 2017 at 19:23
  • To add to this, it seems that on Ubuntu 18 the bcma and/or b43 will load even if blacklisted with modprobe -b. If you reboot and your stops working, do modprobe -r bcma && modprobe -r b43 && modprobe -r wl && modprobe wl and it should work again.
    – jamzsabb
    May 25, 2018 at 17:41

I know this question is pretty old, but here's what worked for me:

  1. Download the current STA driver from Broadcom's website at http://www.broadcom.com/support/?gid=1. Create a new folder and move the downloaded file into it, then cd into the folder. Expannd with tar xvf <filename>.
  2. Unload the current STA driver by running sudo modprobe -r wl.
  3. Remove the current driver's package with sudo apt-get remove bcmwl-kernel-source.
  4. Install the new driver by running make && sudo make install.
  5. Load the new driver with sudo modprobe wl.
  • 1
    I had to also blacklist b43 and bcma which I suspect were being loaded for bluetooth functionality.
    – ctrlc-root
    Nov 13, 2015 at 21:08
  • This worked for me and was pretty easy. Trying to install from apt repo as mentioned above didnt work for me. Apr 25, 2017 at 4:10
  • I couldn't find the driver for this particular adapter on that site. Can you assist me on how to find the download?
    – Javis
    Jun 21, 2018 at 13:06
  • Why do you choose wl over b43
    – user610658
    Oct 12, 2018 at 9:55

I'm on 18.04.2 Cinnamon 4.0.6, Thinkpad T420 BCM4352. This thread still appears relevant since some people like me have old hardware.

I installed via:

#  apt install broadcom-sta-dkms

Watched it build the firmware into initrd file in /boot partition, rebooted, and voila. WiFi active, was able to join an SSID listed in Network-Manager right away.

Couldn't have been easier.

  • This worked for me on Ubuntu 20.04.1 on a Dell XPS 13 laptop (from 2015 I believe), thanks!
    – Nic Wortel
    Jan 7, 2021 at 13:05

Had the same problem with Ubuntu 18.04 on Dell XPS 13 9343, where the wireless adapter recently stopped working after an upgrade. The proprietary driver (bcmwl-kernel-source, which is the only one that supports BCM4352 802.11ac) would not load:

$ sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
$ sudo modprobe wl
modprobe: ERROR: could not insert 'wl': Required key not available

As it turned out, you need to switch off Secure Boot in order to activate this (updated) driver. The easiest way to do that is installing shim-signed and following the required steps:

sudo apt install shim-signed

If it's already installed you can use the following to enroll a new MOK:

sudo update-secureboot-policy --new-key

After a reboot the adapter is working again.

  • You should be able to disable secure boot in the bios menu.
    – Jason C
    May 26, 2019 at 16:16
  • 1
    Thanks for the hint; this set me on a similar track. When I installed bcmwl-kernel-source (from the Additional Drivers tool on 20.04), it was prompting me to set a UEFI password. However, I didn't realise that I had to explicitly choose "Enrol MOK" on the UEFI boot screen that showed on restart so that I could enter that password so that the driver would be loaded correctly. Mar 14, 2021 at 23:17
  • @HarryCutts You should make your comment in to an answer because I didn't know about the Additional Drivers tool and that's what got my BCM94352HMB Wifi Card working on Ubuntu mate 20.04. Then this advice got my Bluetooth working. Jun 6, 2021 at 11:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.