1

When I open an image and without zooming, try to drag to any border (which is ofcourse, by mistake), eog closes and a black screen appears** that says lightdm is starting, and lands me in login screen.

I have no idea why.

  • Is anyone facing the same problem ?
  • Is there a solution?

I tried reinstalling eog and lightdm.


As suggested by @Ferran Rigual, I executed

eog ~/Compiler_Design/SAM_5069.JPG --g-fatal-warnings 2>~/out.txt

and out.txt contained:

(eog:3899): Gdk-WARNING **: eog: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

After logging in, I can see _usr_bin_eog.1000.crash and _usr_bin_Xorg.0.crash created in /var/crash. I don't know what to do with crash files .

0

Execute eog using the console and update your question with the output that appears when the problem is reproduced. That, of course, if you can still read it after the new login.

UPDATE: As stated in its manual page (man eog), maybe you will get more info using the flag --g-fatal-warnings .

  • i tried eog filename > ~/out.txt. When the problem occurred as expected, I logged in to open out.txt and found that it is blank. – MAKZ Feb 26 '15 at 18:15
  • is there any way to log all events including file read, file opened etc ? – MAKZ Feb 26 '15 at 18:19
  • Answer updated, but I would recommend you to execute it like eog filename 2> ~/out.txt, since the error channel is the second one. – ferranrigual Feb 27 '15 at 12:04
  • Yeah. I found something that might interest you. See updated uestion – MAKZ Feb 27 '15 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.