22

I'm trying to extract a rar file is first time is opened then its closed and to reopen the file is failed." an error occured while loading the archive manager" this alert message displayed

  • 1
    Are you sure that the file is complete? If you downloaded it, check its size to see if it is right. – Sigur Feb 26 '15 at 12:11
  • ya sure its complete....im opened it ... once again i wanna to open this file error comes – praveen kumar Feb 26 '15 at 12:14
44

Install unrar to open and extract rar archives.

  1. Open the terminal with ctrl + alt + t
  2. Run

    sudo apt install unrar
    

Now file-roller should open and extract rar archives without error.

If you cannot install unrar, you need to activate the multiverse repository; but, I assume you have them activated as they are by default.

| improve this answer | |
  • 1
    I can confirm, this works in all _buntu distros and Linux Mint – David Tabernero M. Dec 24 '16 at 23:14
  • 1
    Worked for me in 16.04 – seanbreeden Jan 8 '17 at 12:41
  • 1
    Nice. Works on Ubuntu 18.04 aswell – Iron Attorney Oct 24 '18 at 18:57
  • 1
    I got the same error when extracting files from split Rar files. this resolved the issue. – ultimatex Feb 19 '19 at 23:23
0

I have this problem fixed by installing b1freearchiver:

sudo apt-get install gdebi
wget b1.org/smart-download/0/os=deb64/b1freearchiver_current_stable_amd64.deb
sudo gdebi b1freearchiver_current_stable_amd64.deb
| improve this answer | |
0

Something like this happenet to me when a file was parted in some files, and I try from command line: $ unrar e "archive.part1.rar"

| improve this answer | |
  • You should elaborate your answer a little more. This answer it's quite vague... – razor7 Mar 19 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.