0

I'm on Lubuntu 14.04. I'm trying to automatically mount a USB disk attached to an Apple Time Capsule. There seems to be quite a few users who have done this successfully, but for the life of me I cannot make it mount after hours of trying.

My /etc/fstab line looks like this:

//10.0.0.10/MOMO/LaCie\040Rugged /media/LaCie\040Rugged cifs password=fakepassword,rw,iocharset=utf8,file_mode=0777,dir_mode=0777,sec=ntlm,nounix

The Time Capsule is statically set to always be 10.0.0.10. It is named MOMO. The USB disk attached to it is named "LaCie Rugged" and, as far as I know, the space in the name is properly escaped with \040. When I tried to mount it without making the local directory "/media/LaCie Rugged" first, I got an error that the folder didn't exist. I created it, and that error did not show up again, so I know that path is correct and correctly escaped.

I assume the first path--the path to the share on the Time Capsule--is also escaped correctly, but possibly not, as it seems to be the reason for getting the error "Unable to find suitable address" or so the internet tells me.

SO. I try to ping the IP address and it works.

$ ping 10.0.0.10
PING 10.0.0.10 (10.0.0.10) 56(84) bytes of data.
64 bytes from 10.0.0.10: icmp_seq=1 ttl=64 time=85.7 ms
64 bytes from 10.0.0.10: icmp_seq=2 ttl=64 time=107 ms
64 bytes from 10.0.0.10: icmp_seq=3 ttl=64 time=129 ms
64 bytes from 10.0.0.10: icmp_seq=4 ttl=64 time=49.7 ms
64 bytes from 10.0.0.10: icmp_seq=5 ttl=64 time=70.9 ms
64 bytes from 10.0.0.10: icmp_seq=6 ttl=64 time=95.0 ms
64 bytes from 10.0.0.10: icmp_seq=7 ttl=64 time=15.8 ms
^C
--- 10.0.0.10 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6008ms
rtt min/avg/max/mdev = 15.878/79.149/129.265/34.919 ms
andy@eeePC8G:~$ sudo mount -a
Unable to find suitable address.

But when I try to run sudo mount -a, I always get the error "Unable to find suitable address."

I have no clue why it doesn't work or what that error is pointing out. I need help. :(

How do I automatically mount a Time Capsule share in Lubuntu using fstab?

1

From the Ubuntu forum:

  • Find the netbios name of the device: nmblookup -A 10.0.0.1
  • List the device's samba shares querying using the netbios name instead of the IP address: smbclient -L //<device_netbios_name>
  • Mount using a mount point corresponding to a Disk type of share: in fstab: //<device_netbios_name>/<device_netbios_disk_share> /media/LaCie\040Rugged cifs password=fakepassword,rw,iocharset=utf8,file_mode=0777,dir_mode=0777,sec=ntlm,nounix
  • I tried this command and got "Connection to 10.0.0.10 failed (Error NT_STATUS_CONNECTION_REFUSED)" so I tried to send the Time Capsule's disk access password with smbclient -L 10.0.0.10 -P fakepassword and I got "Failed to open /var/lib/samba/private/secrets.tdb ERROR: Unable to open secrets database" – iynque Feb 26 '15 at 4:44
  • @iynque Sorry, i meant smbclient -l 10.0.0.10. It should prompt you for a password – kos Feb 26 '15 at 12:15
  • Thank you for the clarification. -l is for [-l|--log-basename=LOGFILEBASE], -L is for [-L|--list=HOST]. Are you sure -l is right? When I enter smbclient -l 10.0.0.10 I get "Unable to open new log file '10.0.0.10/log.smbclient': No such file or directory" along with a paragraph of command usage info from the man page (which usually means, "You're doing it wrong."). From your answer, it sounds more like you want the list command, not the log command. Either way, they're not working for me. – iynque Feb 26 '15 at 17:15
  • @iynque Ok, sorry for the overall poor response. Actually -L or --list is what i meant. I have no idea why it didn't work, but i googled this a bit and i found something on the ubuntu forum, so i edited my answer with suggestions made in such post, see if that helps instead – kos Feb 26 '15 at 17:39
  • I've been using gigolo to connect; just getting back to trying this. On the second step, I see no shares for some reason (even though gigolo connects to them just fine): pastebin.com/Kn9u4wk7 This seems like a problem. :D Thanks for your help so far! – iynque Mar 14 '15 at 5:02
0

I added this line to the end of my fstab then pressed enter and saved it

//10.0.0.137/examplenetworksharename /Folderyouwanttomounttheshareto cifs username=exampleusername,password=examplepassword,file_mode=0777,dir_mode=0777,sec=ntlm,nounix 0 0

I also had to add a disk user to the time capsule using airport utility on my mac as it needed a username and password and the time capsule only has a password by default.

Couple of other things worth noting are that by default the time capsules shared volume is called Data the default IP address when the time capsule is setup to create a network is 10.0.1.1 and when I created my mount folder I assigned permissions for my local Linux account to be honest I'm not sure if that has any affect on whether you can mount the share or not but I've found it a helpful step in the past when adding samba shares to the fstab.

Once the fstab is updated rather than restarting your PC run sudo mount -a to test the new configuration.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.