1

I have difficulties seeing, so I tried to change my cursor using the instructions from Ubuntu 11, 12 but nothing worked. I have found no one on this Internet with my problem. I run Ubuntu 14.04 and gnome 3.9, I have dconf-editer, compiz-config and they don't do anything to my computer.

1
  • If the answer below does not work PM me and I'll try to help/fix it.
    – Rinzwind
    Feb 25 '15 at 17:51
4

14.04 introduced a new dconf setting called cursor-scale-factor setting. This should make it 48:

echo "Xcursor.size:48" > ~/.Xresources && gsettings set com.canonical.Unity.Interface cursor-scale-factor 2

The cursor is large in Ubuntu software center, all of the Libre Office programs and in several other pieces of software.

But when pointing it to the launcher, the top panel, in Nautilus and in browsers the cursor is still small. So this is not working properly...


Better method: Change the mouse cursor theme. There is a tool for that called galternatives and it is in the default repository:

sudo apt-get install galternatives

and follow these directions:

Preliminary:

Put new cursor folder in /usr/share/icons. Create cursor.theme file if needed. You can get some themese on gnome-look.

Start the program:

galternatives
  • You are asked for your password.
  • Select x-cursor-theme from the list in the left.
  • To add a new cursor, click 'Add' button and browse in the popup window to the new cursor's directory in /usr/share/icons.
  • Click Open, and select the file cursor.theme
  • Click ok.
  • Click ok.
  • New cursor becomes available in the main window.
  • Select it and close.
  • It will become active after log out.

For Unity: in addition to the above, use 'advanced settings' to complete the job and change the gnome cursor.


edit: it is a long standing bug. The bug also has a workaround

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.