6

unknowingly I have placed

gnome-terminal --geometry=120x80+50+50

command in Gnome terminal's Edit->profile and preferences->general's run custom command.
Now when I start terminal, it keeps restarting itself, therefore I'm not able to go to settings again.

How can I fix this problem?

  • 3
    You should remove the folder ~/.gconf/apps/gnome-terminal, log out / in. The files are loaded on login. (and existing settings probably simply (re)written if you start gnome-terminal during the same session). – Jacob Vlijm Feb 25 '15 at 14:22
  • @JacobVlijm Thanx a lot. IT worked. now terminal is working fine. :D – Sachin Agarwal Feb 25 '15 at 14:40
2

You need to remove the folder ~/.gconf/apps/gnome-terminal (where the profiles are stored), and log out and back in. Changing the files manually during your session won't help, since they simply will be overwritten by the previous settings of the same session if you start gnome-terminal again.

So:

  1. remove the folder ~/.gconf/apps/gnome-terminal
  2. log out and back in. You will lose the possible settings changes you made, but you will have your gnome-terminal back.
  • I want to solve this problem as well as keep my settings , how can I do that? I have been searching for hours, perhaps I am not a good googler. I deliberately want to run this command on terminal startup. I put it under a script file and imported it in the bashrc file. I am using a non-login shell. Perhaps , there is problem with the script itself. Please help me out! I am stuck. – 0decimal0 Jul 19 '15 at 11:35
4

You can manually edit your gnome terminal settings by navigating to ~/.gconf/apps/gnome-terminal/. Just edit the xml file with gedit and remove the offending line.

I'm unsure whether you need to edit the file directly in ~/.gconf/apps/gnome-terminal/ or the one in ~/.gconf/apps/gnome-terminal/Profile/Default, you may need to try both.

  • the file in ~/.gconf/apps/gnome-terminal/ is empty And after editing the file in ~/.gconf/apps/gnome-terminal/Profile/Default nothing is happening. the file is again reverting back after starting terminal – Sachin Agarwal Feb 25 '15 at 14:16
  • 2
    @SachinAgarwal Don't forget to log out and log back in after you have made the edits – solstice333 Apr 7 '17 at 18:37
1

Navigate to ~/.gconf/apps/gnome-terminal/Profile/Default

Open %gconf.xml file and find the entry name "custom_command". Remove the stringvalue value and save the xml file.

<entry name="custom_command" mtime="xxxxxxxxxx" type="string">
                <stringvalue>your command here</stringvalue>
</entry>

Hope this helps.

  • Tried but when running the terminal after doing this, the file is again getting that line – Sachin Agarwal Feb 25 '15 at 14:31
  • @SachinAgarwal see my comment to your question. – Jacob Vlijm Feb 25 '15 at 14:33
  • Log out and log back in after making the edits – solstice333 Apr 7 '17 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.