0

This original question has NOT been answered and is NOT a duplicate question so I am reasking it: Way to remove unwanted/unused wifi networks from Network Indicator Menu?

There should be a way to stop the Network Indicator menu from displaying completely unused/unwanted Wifi network entries in the dropdown.

On my indicator menu, there are more than a dozen networks displayed but I only ever connect to one. Why do I have to do deal with selecting from so many networks when I only ever connect to one? I should be able to configure Network Indicator to only display the one wifi network I connect to (the one wifi network that shows up in Network-Indicator > Edit Connections > Wifi).

How can I hide/remove the networks that I never use?

If any of the moderators bothered to read the original question and the so-called duplicate, they would understand they are not the same question. I am not asking about networks I have connected to. I am asking about the display of networks I have NEVER connected to. Networks I will NEVER connect to. I want to hide these networks from showing in the Network Indicator dropdown. The question this is supposed to be a duplicate of does not ask about this and none of the answers from that question even attempt an answer of what I am asking.

The comments from my original post of this question clearly delineate on how my question is NOT a duplicate.

see askubuntu.com/questions/227297/… – Rinzwind 21 hours ago

That will not prevent Networkmanager from showing the networks in the list; it will only prevent reconnecting to them if there has ever been a connection. – Jos 21 hours ago

@Jos If they are within scan range, they will appear. If not, say, for example, a network he joined at the cyber cafe, they will be removed. – chili555 21 hours ago

As I understand it, there are more than a dozen networks within scan range, and OP doesn't want to see those. That is not the same as removing networks he has ever joined. – Jos 21 hours ago

Yes, Jos is correct. I have never connected to any of the shown networks. I will never connect to them. And yet they are always displayed. At a minimum it seems there should be a way to move them to the "More networks" folder/container. Most of the networks show up there. But why can't all unused networks show there? The dropdown menu should only display networks I can/want to connect to. – user308393 20 hours ago

  • You could, if this is a stay-at-home computer, remove NM altogether and configure your wireless manually. No dropdown at all; no unwanted networks! – chili555 Feb 25 '15 at 14:49
  • @muru: no mind-reading involved. NM-indicator display networks I've connected to and that's it. The other networks (the ones I never connect to) appear in the "More networks" folder until I connect to them (or better yet, until they are in range). But having networks I never ever connect to populate (and crowd up the NM-indicator) is problematic. – user308393 Feb 26 '15 at 5:18
  • @chili555: interesting idea. Is there anything I should look out for in trying this? I make use of both Wired and Wireless (one SSID) networks. Would I still be able to enable/disable the wireless radio without NM installed? – user308393 Feb 26 '15 at 5:20
  • @user308393 NM is just one network service. There are others (like Wicd, for example), or you can do it all manually using via /etc/network/interfaces. Actually changing NM's UI would be a feature request that should be posted on their bug tracker. – muru Feb 26 '15 at 5:22
  • @user308393 It's probably easier to tell you in an answer. – chili555 Feb 26 '15 at 14:40
1

If you wish to change to manual methods, I suggest you open a terminal and do:

sudo -H gedit /etc/network/interfaces

Use nano or kate or leafpad if you don't have the text editor gedit. Amend the file to:

auto lo
iface lo inet loopback

#auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
wpa-ssid <your_network>
wpa-psk <your_key_in_clear_text>

Proofread carefully, save and close the text editor.

Notice I have commented out the 'auto eth0' line. This implies you will use wireless by default. The system will only start wireless on boot. If you wish to stop wireless and start ethernet, in a terminal:

sudo ifdown wlan0 && sudo ifup -v eth0

The -v for verbose will show enough information for you to see that the system connects. To return to wireless is the reverse.

I do not believe NM turns off the wireless radio; it merely disconnects.

Test to be sure it is working as expected.

sudo service network-manager restart
sudo ifdown wlan0 && sudo ifup -v wlan0

It may take a reboot.

Once you are satisfied that it's correct, you may then remove NM:

sudo apt-get purge network-manager
sudo apt-get autoremove

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.