1

When I try to login with lightdm my monitors go dark and then switch off before taking me back to the lightdm login screen. I get a message telling me:

Could not switch to the monitor configuration

could not set the configuration to CRTC 64

I'm running unity in a multi-monitor set up with 3 monitors. Before this error started occurring I had 2 monitors active and one switched off. I played Minecraft and upon closing the program there seems to have been some kind of problem setting the resolution and all of my screens went black except a small (about 640x480) window in the top left hand corner of the first monitor.

I tried using the display manager to fix the resolution but after applying the settings the screens both displayed in some kind of 4:3 resolution (1280x1024 maybe). I figured maybe I needed to log out and in again, and ever since then I haven't been able to start a unity session.

I installed xfce4 and I can log into that but really I want unity back. I have tried reinstalling ubuntu-desktop and unity, but I'm still receiving the same error. I've tried checking the permissions for .Xauthority and .ICEauthority, but they look fine.

Here is my output for lshw -c video:

 *-display               
   description: 3D controller
   product: GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:47 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
   description: VGA compatible controller
   product: 3rd Gen Core processor Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:44 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

Everything looks good if I modinfo i915, but if I modinfo nvidia I get modinfo: ERROR: Module nvidia not found. nvidia should be my default display driver.

Here is the contents of my xorg.conf:

Section "ServerLayout"
Identifier "layout"
Screen 0 "nvidia"
Inactive "intel"
EndSection

Section "Device"
Identifier "intel"
Driver "intel"
BusID "PCI:0@0:2:0"
Option "AccelMethod" "SNA"
EndSection

Section "Screen"
Identifier "intel"
Device "intel"
EndSection

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1@0:0:0"
Option "ConstrainCursor" "off"
EndSection

Section "Screen"
Identifier "nvidia"
Device "nvidia"
Option "AllowEmptyInitialConfiguration" "on"
Option "IgnoreDisplayDevices" "CRT"
EndSection

What further steps should I take to further diagnose this problem and restore my unity session?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.