-1

I have Ubuntu 14.04 installed. It was working fine until I installed Virtualbox, and then without installing any guest OS under Virtual box, ran an system update when prompted by Ubuntu. Now when I log into Ubuntu, all I get is a blank default desktop screen (the peachy pink mauve one) and cannot access menus, cannot access terminal CTRL+ALT+T right clicking does nothing, although the mouse cursor still appears and can be dragged around the empty screen. CTRL+ALT+F1 brings up a terminal.

I have a lot of data on my Ubuntu installation that I do not want to lose, and would like to secure it/save/backup in case something goes wrong. I have a bootable Ubuntu 14.04 DVD which works, and using this I can run another Ubuntu 14.04 without installing. When I run the Ubuntu without install from the DVD, I can only see some of the data, because I get the message, you do not have the necessary permissions to access this folder or some words to that effect. Any help in fixing my problem is greatly appreciated.

0

Try following the answer on AskUbuntu Post and see if your desktop Unity is back.
If you get to step 5 in the following link, but do not see Unity on the list try this: sudo apt-get -f install && sudo apt-get --reinstall install unity

  • sudo apt-get -f install && sudo apt-get --reinstall install unity This solution pretty worked in my case too #SELF NOTE – Anonymous Jan 8 '16 at 2:30
0

Since your data is important, I would try again to back it up. It's not entirely clear in your post if you remembered to get root when you were on the DVD. If you are in a terminal you can do this with the command sudo su. If you tried that and still have permissions issues, you may need to gain root another way. See this post (https://askubuntu.com/a/70543/355147) about the difference between sudo and su.

Now back to fixing your installation...

After doing some searching, I found this post that might help you (Unity crash in Ubuntu 14.04).

If not, what type of video card do you have installed? I've had similar issues on Linux Mint where upgrading causes the GUI to crash on boot. The fix for me has been to re-install the NVidia driver using this post (https://askubuntu.com/a/432940/355147). This may not apply to your situation, but since there are no logs posted it's tough to help.

Logs and more information:

So a couple questions that can help the community understand your situation a little.

  1. I don't think VirtualBox is the issue, but I'm curious if you installed VirtualBox using apt-get or if you downloaded the .deb package from their website.
  2. Post some logs. Start with /var/log/dmesg, /var/log/vbox-install.log, /var/log/Xorg.0.log if you have them.
0

In my case the situation was simple. VB simply has overridden the boot for ubuntu.

On startup go to settings. Go to boot. Click add boot. Click those three dots. Click on EFI (disk partition storing the grub) and choose the grub File. Name the boot and restart. And that was it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.