3

I'm running a dell XPS 13 (developers edition). I had Ubuntu 14.04 from the beginning and for about 2 months everything was working great. After a while, sometimes when i had my earplugs plugged in, the sound suddenly stopped, but after a restart it was ok. 2 weeks ago, restart didn't fix it so i had to sudo alsa force-reload or to reinstall it

sudo apt-get remove --purge alsa-base pulseaudio

sudo apt-get install alsa-base pulseaudio

Everytime i restarted i had to do one of 2 things above in order to have sound. 15 days ago it started showing 'dummy output' and nothing can be done. I tried all the recommended ways i found: 1. update kernel 2. Open the terminal and edit speech-dispatcher file by using the following command: sudo gedit /etc/default/speech-dispatcher and change RUN=yes to RUN=no 3. running sudo nano /etc/modprobe.d/alsa-base.conf and adding

options snd-hda-intel probe_mask=1 model=dell-laptop
also tried model=dell-m23 and dell-m82 and dell-bios

but nothing happened. Then i tried options snd-hda-intel probe_mask=1 model=auto and it seemed to fix the problem but the next day had the dummy output again. i'd had to sudo alsa force-reload a couple of times, restart and the sound would come back again. Now not even this works.

Some information

sudo aplay -l gives

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

cat /proc/asound/card0/codec* | grep Codec gives

Codec: Intel Haswell HDMI

Any ideas?

1

I experienced a similar problem. In my case speech-dispatcher was not installed, but that doesn't seem to be the case for you. I recommend running:

sudo apt-get install alsa-base alsa-utils alsa-tools libasound2 libasound2-plugins

this will ensure that all the necessary packages are installed. Follow this with:

sudo alsa force-reload

to reload your alsa settings.

  • 2
    I already had tried your solution, and did it again just in case. It didn't work. – Dimitris Ktistakis Feb 25 '15 at 12:53

protected by Community May 30 '15 at 11:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.