0

Actually there is a similar question on the community before as well but what I am facing is a different problem. Also there the person has not properly posted the status of his grub. Actually I installed windows 8.1 on my laptop & it was working fine. Then I installed Ubuntu on another partition & as per the instructions again booted using live usb of Ubuntu to repair GRUB using boot repair. You can find the boot repair report . But now the GRUB menu is not showing Windows option at all & I am unable to boot into Windows. Please help me - it's urgent!! Any kind of help will be appreciated.

  • Usually you have to select which OS to boot in your BIOS, under teh UEFI boot menu. Location varies by BIOS – Panther Feb 25 '15 at 4:35
  • Can you elaborate a little more... – Madhusudana Feb 25 '15 at 4:37
  • askubuntu.com/questions/221835/… - see the TROUBLESHOOTING section. In your case , the bios is selecting Ubuntu rather then windows. As i said it varies by BIOS – Panther Feb 25 '15 at 4:39
0

Windows 8 does not shut down properly by default. I suspect this is your problem. In your code I see:

Failed to mount '/dev/sda3': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
mount /dev/sda3 : Error code 14
mount -r /dev/sda3 /mnt/boot-sav/sda3

Try mounting as suggested and run

sudo update-grub
  • Actually mount both sda1 and sda3 – Carl Fletcher Feb 25 '15 at 3:46
  • 1
    I am a new user - can you please tell me how to mount. – Madhusudana Feb 25 '15 at 4:24
  • I tried to mount but it's showing the following message - "Windows is hibernated, refused to mount. Failed to mount '/dev/sda3': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option." – Madhusudana Feb 25 '15 at 4:35
  • Did you: mount the volume read-only with the 'ro' mount option – Carl Fletcher Feb 25 '15 at 4:44
  • Another option. And I'm not sure of the result. Is to completely power down - remove power supply and battery. The boot back to Ubuntu and try update-grub again – Carl Fletcher Feb 25 '15 at 4:47
0

First of all thanks to Carl for providing a hint - big hint. Actually my drives were not getting mounted even by using mount -r /dev/sda3 /mnt/boot-sav/sda3 but then I serached over net. I found out that my windows was not properly shutdown previous time, so the grub is showing trouble. So, I needed to manually mount the partitions & to achieve that I had to go to Disks tool in Ubuntu & follow the following steps as given in this link. Then, I went to GRUB configure(has to be downloaded) to set the display resolution to 680*480 minimum. Then grub starts showing Windows. Boot into windows, download appropriate display drivers & then get back to Ubuntu to set back Grub to its original resolution. Everytihng is okay now..

-1

Just type the following command in a terminalCtrl+Alt+T

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.