3

How can I increase the mouse scroll speed in GNOME 3 and ensure that it works after a restart as well?

Currently getting about 3 lines per scroll, I'd like to increase that.

I've tried following a few guides, but they don't work with 14.04

TIA!

4

You could try imwheel, but there seems to be no further development.

Install it with

sudo apt-get install imwheel

Create a configuration with

nano ~/.imwheelrc

and fill in the following

".*"
None,      Up,   Button4, 100
None,      Down, Button5, 100
Control_L, Up,   Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L,   Up,   Shift_L|Button4
Shift_L,   Down, Shift_L|Button5

You control the speed with these two lines:

None,      Up,   Button4, 100
None,      Down, Button5, 100

You can use values between 0 (slow) and 100 (fast).

Source

1
  • @AsianXL Were you satisfied with my answer? Then give me a upvote (∧). If I could solve your problem, then it would be nice if you'd mark my answer (✓). ;) – A.B. Apr 18 '15 at 14:58
2

Have you tried imwheel ? There is a handy script for it. It lets you to set a config for imwheel with a simple GUI. And you can set imwheel to launch at startup. (If you have tried imwheel before, it's recommended to delete the old config before using the script. It can be deleted by: rm ~/.imwheelrc)

  1. Get imwheel: sudo apt-get install imwheel
  2. Get the script and save it somewhere with your favorite text editor and name it as mousewheel.sh (i'll have it below)
  3. Mark the script as executable (right click the .sh file -> Properties -> Permissions: tick "Allow executing file as program")
  4. Optionally you can create a shortcut for the script
  5. Just run the script and adjust the speed to your liking
  6. You can set imwheel to launch at startup from Startup Applications or launch it manually from terminal with command imwheel (and killall imwheel to stop it)

Script:

#!/bin/bash
# Version 0.1 Tuesday, 07 May 2013
# Comments and complaints http://www.nicknorton.net
# GUI for mouse wheel speed using imwheel in Gnome
# imwheel needs to be installed for this script to work
# sudo apt-get install imwheel
# Pretty much hard wired to only use a mouse with
# left, right and wheel in the middle.
# If you have a mouse with complications or special needs,
# use the command xev to find what your wheel does.
#
### see if imwheel config exists, if not create it ###
if [ ! -f ~/.imwheelrc ]
then

cat >~/.imwheelrc<<EOF
".*"
None,      Up,   Button4, 1
None,      Down, Button5, 1
Control_L, Up,   Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L,   Up,   Shift_L|Button4
Shift_L,   Down, Shift_L|Button5
EOF

fi
##########################################################

CURRENT_VALUE=$(awk -F 'Button4,' '{print $2}' ~/.imwheelrc)

NEW_VALUE=$(zenity --scale --window-icon=info --ok-label=Apply --title="Wheelies" --text "Mouse wheel speed:" --min-value=1 --max-value=100 --value="$CURRENT_VALUE" --step 1)

if [ "$NEW_VALUE" == "" ];
then exit 0
fi

sed -i "s/\($TARGET_KEY *Button4, *\).*/\1$NEW_VALUE/" ~/.imwheelrc # find the string Button4, and write new value.
sed -i "s/\($TARGET_KEY *Button5, *\).*/\1$NEW_VALUE/" ~/.imwheelrc # find the string Button5, and write new value.

cat ~/.imwheelrc
imwheel -kill

Source: https://www.youtube.com/watch?v=i-acwJs9UfY

2
  • Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, merged into another one or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... – Fabby Apr 16 '15 at 12:58
  • 1
    @Fabby Thanks for the tip. Makes 100% sense. I have now edited the post. First post here :) – wayzhc Apr 27 '15 at 12:46
0

Ok, Gnome 3 is leaving its toys and settings all over the place. Somehow my settings changed when I spilled coffee on my mouse, and neither the "stupid settings" or the "advanced stupid settings" would fix it. I think restoring the defaults worked:

Here's how I fixed this:

$ gnome-control-center

Mouse & Touchpad -> Mouse -> Mouse Speed (max)
Mouse & Touchpad -> Mouse -> Natural Scrolling (off)


$ gnome-tweaks

(install it if you don't have it: sudo apt install gnome-tweak-tool)

- Menu -> Reset to Defaults
- Change my theme back
- Keyboard & Mouse -> Alleleration Profile -> Adaptive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.