1

symptom: can not boot from SSD after installing ubuntu server 14.04. BIOS menu keeps returning back. No dual booting.

setup:

  • Lenovo T430s with windows 8 preinstalled.
  • BIOS boot menu supports both legacy and UEFI.
  • created GPT with gparted. /dev/sda2 is where i installed ubuntu. /dev/sda6 FAT32 is the EFI system partition.
  • /dev/sda6 has flag boot and esp set (set from ubuntu install image).
  • i installed server image following the "manual" option. when it asked where to install grub, i specified /dev/sda6. no error.
  • successful install.

diagnoses: I mounted both /dev/sda2 and /dev/sda6 on gparted live CD terminal. it turns out /dev/sda6 has nothing in it. Why? and how do i fix it? Thanks!

0

It turns out I booted the installer into the BIOS mode. See this article.

I tried to boot the installer into UEFI mode on that lenovo but the screen flashed once and then it just halted.

I tried to use the same live USB on another PC and it installed ubuntu to UEFI mode just fine. So there is something wonky with that Lenovo.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.