1

I dug an old Mac PowerPC g5 out of my garage, and the MacOS install on it appears to be trashed.

It can boot into OF Diagnostics, and I can get into the OF Console (egads, what an alien world!).

I've tried booting from a USB stick with Ubuntu server on it, with no luck.

I've since determined that openfirmware doesn't seem to like any of my USB sticks as bootable media, and switched to CDs.

I've verified the checksum for the downloaded image as well as the burned CD, and just to verify that I'm not crazy, reburned a different distro (debian) to another CD and confirmed the checksums.

Every time I try to boot from CD, I follow these steps:

Power on Hold 'C' Key until system begins booting from the optical drive. Wait for bootloader to load

Then, I get the yaboot prompt, and seemingly no matter what options I pass to it, I get this response:

quickly loads Elf64 kernel, then white framebuffered screen showing

done
found display   : /pci@0,f0000000/NVDA,Parent@10/NVDA,Display-A@0, opening... done
copying OF device tree....
Building dt strings....
Building dt structure...
Device tree strings 0x0000blahblah
Device tree struct  0x0000blahblah
Calling quiesce...
_

then it hangs. It slowly spools all the fans up to full speed (holy crap, this thing sounds like a small plane taking off!) But goes no further in the install/boot process.

I can repeat this hang with every bootable linux cd I've tried. Ubuntu Server, Ubuntu LiveCD, Debian, etc etc.

I've tried passing it "video=ofonly" "vga=XXXX" (different options all make no difference) acpi switches to turn off, limit to the basics for install, etc. Nothing I try seems to help.

What am I missing? Am I being impatient, should Quiesce take a long time to complete?

Sincerely, Pulling my hair out arguing with a ton of aluminum that sounds like a fighter jet.

2
  • I just tried ubuntu-12.04-alternate-powerpc.iso and verified the checksums. same issue, hangs after "Calling quiesce..." then spins the fans up to full speed. – Aaron Casper Feb 24 '15 at 19:06
  • I've just tried gentoo minimal as well, and no luck. This leads me to believe it's an issue with the machine. I did at random get a boot to get beyond calling quiesce and then give an error referring to invalid memory access. I've tried reseating all of the dimms and clearing NVRAM – Aaron Casper Feb 27 '15 at 4:04
1

I ran into the same problem, didn't find any info on a solution but got it to work now.

I found out it's some kind of data flush/update command so I guessed that setting the clock to a realistic time/date (since the comp is old and the battery probably dead the date resets to lika 1909). After I set my clock straight (with a live CD) the boot process did not get stuck. Try it. Might work for you too. :)

1
  • 1
    Necro thread, but this actually fixed it. I dug the old lump back out and tried again. – Aaron Casper Apr 10 '19 at 21:45
0

Disconnecting the network cable did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.