2

After having installed Ubuntu 14.10 freshly, I still have the same error that I already had in 14.04 and 12.04. The desktop sometimes just freezes. To use the desktop again I press Ctrl+Alt+F8 and then Ctrl+Alt+F7 to basically reload the desktop. I tried around a bit, installing Unity, KDE4, Gnome 3, Mate, Cinnamon, xfce, and I get the same error with all desktops. I still can continue my work, but it is truely annoying and I believe I am not the only one out there having this problem.

I already did some research, but have not found anything helpful.

My laptop is a Dell XPS with a Intel(R) Core(TM) i7-2630QM CPU and an NVIDIA GF116M [GeForce GT 555M/635M].

Is anybody familiar with this apparent bug?

[EDIT]:

The output of lspci -nnk | grep -iA2 VGA is:

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
        Subsystem: Dell Device [1028:0571]
        Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF116M [GeForce GT 555M/635M] [10de:124d] (rev a1)
        Subsystem: Dell GeForce GT 555M [1028:0571]
        Kernel driver in use: nvidia
  • 2
    are you using proprietary driver? add the output lspci -nnk | grep -iA2 VGA – JoKeR Feb 24 '15 at 16:57
  • I used the recommended driver that is offered after the installation by the desktop environment. (Edit above) – Socrates Feb 24 '15 at 20:28
  • run in terminal prime-select nvidia and then prime-select query to check if it says nvidia and reply. Also you might wanna look here wiki.ubuntu.com/Bumblebee – JoKeR Feb 24 '15 at 20:43
  • I think you're correct to suspect something hardware/graphics driver related since the bug shows up in different OS versions. Apparently you have a hybrid graphics system with an Intel and an Nvidia GPU. You might want to try the Bumblebee Project: wiki.ubuntu.com/Bumblebee – atmelino Feb 24 '15 at 21:02
  • Thank you @JohnnyEnglish and atmelino for your answers. Bumblebee provided the answer to me. I answered to my posting and will mark it as the adequate answer in 17h from now on. – Socrates Feb 25 '15 at 23:51
1

The solution to this problem is in wiki.ubuntu.com/Bumblebee.

Easily done by running the following command:

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic
sudo reboot
  • Had same issue with propiertary drivers. Bumblebee did the trick. Install primus aswell.. – aXept Feb 25 '15 at 23:54
0

I had a similar problem and searching on google I found that was due to multiple nvidia driver versions installed. Unfortunately I didn't find the thread, but it was something close to Nvidia proprietary driver hangs/freezes/blank screen at login in 13.10

I downloaded the right driver from the Nvidia website, then I removed all the nvidia drivers installed on my system, reboot, got a console and installed the driver just downloaded. Perhaps you should even reinstall the kernel package after installing the nvidia driver

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.