10

How is the default browser set in Lubuntu 14.10?

In the absence of 'System Settings' (which is used in Ubuntu 14.10 etc), how are the default applications set in Lubuntu? I'm running Firefox and Chrome (and may use others), whilst Firefox seems to be set as the default browser, Chrome says it 'cannot determine or set the default browser' and had no method of setting the default as Chrome.

2
  • Have you tried un-installing the browser you don't want to use? – Elder Geek Feb 24 '15 at 16:47
  • 1
    No. I appreciate that's would fix the problem, but I'd prefer to have two or more browsers available. – ChrisF Feb 24 '15 at 16:54
17

run the following in a terminal:

sudo update-alternatives --config x-www-browser

It will present you a list of available browsers that are installed, and lets you select your default one.

5
  • Thanks Kamaradski, but that doesn't appear to work. Update alternative etc. opened & shows 4 browser (chrome {in automode}, firefox {manual}, chrome {manual}, & opera {manual}). It was set to chrome {auto}, which I changed to chrome {manual}. However, when selecting a link in my email client (thunderbird) it still opens in Firefox, even after a restart. – ChrisF Feb 24 '15 at 18:02
  • @ChrisF Both Thunderbird and Firefox are Mozilla products. This is not surprising as firefox is installed. Try uninstalling firefox, run the config, choose your default, test the link and see if that works. If so, you could try reinstalling firefox and testing again. You might consider this useful as well: support.mozilla.org/en-US/kb/… – Elder Geek Feb 25 '15 at 14:08
  • 1
    Thanks Elder Geek, but that doesn't provide a solution. I tried removed Firefox (using Synaptic) but as soon as its reinstalled (both before and after running the update-alternatives config) it still fires up when selecting links in Thunderbird. Your Mozilla link doesn't include Lubuntu. As you suggest, this looks like a Mozilla issue, that Thunderbird is overriding the OS default preferences. I think this means Firefox has to be removed (which is a shame, since I quite like it) and I'll use Opera & Chromium as additional browsers, unless a solution is found. – ChrisF Feb 26 '15 at 13:54
  • This worked flawlessly with Lubuntu 14.04 with LXDE daily ppa installed. I didn't even need to restart or logout/login the pc. – Arda Oct 25 '15 at 21:39
  • It doesn't work on Lubuntu 19.10 too. Although Chrome is already set a default browser with update-alternatives, but Chrome still asks for setting it as default browser, and my Firefox is still used as default browser. – Hung Tran Jan 9 '20 at 0:41
5

Click Start bar -> Preferences -> LXQT Settings -> LXQT Configuration Center -> Sessions Settings and then in 'web-browser' click 'search'.

The default folder should be /usr/bin.
Scroll and find 'google-chrome'

If it's not there, download google chrome from here and install it with 'Discover'.
Then redo the steps above.

Once set, re-login, or restart.

1

In Lubuntu there is an application in the menu called default applications for lxsession. It is under Preferences. Once you open it, merely navigate to web browser and choose the browser that you would like to be the default choice. Alternatively, there is a choice in Firefox and there probably is one in chrome as well where you choose it to be the default browser. In Firefox go to Edit->Preferences->General.

1
  • Thanks Rex, but that didn't work, even after a restart. – ChrisF Feb 25 '15 at 9:05
1

Go to preferences -> configure alternatives, in list groups, choose gnome-www-browser and set it to google-chrome-stable with the lowest priority. To test how it works, type gnome-www-browser in the console and chrome should pop off.

2
  • 1
    i've forgot to mention that it worked on lubuntu 18.10 – oussoulessou Feb 14 '19 at 0:50
  • It works on Lubuntu 19.10. However, the menu item is "Alternatives Configurator". – Hung Tran Jan 9 '20 at 0:46
0

Setting the default browser depends on the application you wish to launch your browser from, because Linux has several methods of determining default applications, so applications use different methods.

For example, the Lubuntu/LXDE default terminal, LXTerminal, uses xdg-open to launch a browser when a URL is clicked. Setting your default browser via update-alternatives will in that case have no effect.

As you mentioned Thunderbird in some of your comments, things seem to be even more complicated when it comes to Thunderbird. (Refer to Bug 724461 as well as this blog post about how Thunderbird chooses a browser.)

In short, if you tried other methods and things still don't work out, you could run the following commands to update xdg-open's default application for Web URLs to Chrome:

sudo xdg-mime default chromium-browser.desktop x-scheme-handler/http
sudo xdg-mime default chromium-browser.desktop x-scheme-handler/https

This approach works for LXTerminal on Lubuntu 14.10 and should also work for Thunderbird.

0

Run below command to update default settings:

sudo xdg-settings set default-web-browser google-chrome.desktop
sudo xdg-mime default google-chrome.desktop x-scheme-handler/http
sudo xdg-mime default google-chrome.desktop x-scheme-handler/https
sudo xdg-mime default google-chrome.desktop text/html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.