4

I a running Ubuntu 14.04 LTS, wine 1.6 and have installed Adobe digital editions 4.0.

I originally downloaded a small .exe file and it seems to have installed (with wine windows program loader) but cannot seem to launch it.

I have tried by right clicking and opening with wine browser (didn’t seem right), and a wine application (I have two of these when I right click but neither work).

I then re-installed ADE twice (seems to just install over the top of the other installation, deleting then replacing some .dll files) and re-tried launching it, including through wine explorer.exe.

Then I found some links on this Q&A site and installed manually using ADE_4_0_Installer.zip from adobe. It seems to have just done the same thing, installed and deleted then replaced .dll files.

The program is there in my ~/.wine folder where it should be (in a sub,sub sub folder where it installs by default).

It all seems OK and should have worked but I'm just wondering which way I should tell wine to launch it so that it does - every attempt just creates that small white spinning disc which suggests something is happening but nothing does.

I am assuming that installing over and over hasn’t messed things up (??), it would appear there is no duplicates and the first install did not work either.

any help greatly appreciated.

added later: ADE version 4.0 cannot run from command line as folder is "Program Files (x86) so the spaces and brackets as in windows wont work - does this effect the GUI function?

  • Welcome to Ask Ubuntu! ;-) Could you please give us a bit more information like: what version of ADE are you installing? Because the wine App DB mentions some particularities depending on ADE and Wine combinations. – Fabby Feb 24 '15 at 7:07
  • Also, trying to start the application from the command line may be helpful - most likely it crashes with an error message which you'll be able to see printed on the console. Just do something like cd ~/.wine/where/the/program/is; wine the_program.exe – Sergey Feb 24 '15 at 7:19
2

Installation via winetricks worked very well for me.

Install winetricks:

sudo apt-get install winetricks

then run winetricks and follow the instructions. Run ADE from the dash.

  • I have installed winetricks,then ADE again (seems to be installing the same with slightly different graphics/boxes etc then through wine 1.6) BUT still cannot run ADE - it says its a 64bit application and i need to run it as 32 bit, is this progress or a wall? I have checked some documentation that says i need to re-install wine as a 32 bit program - but i already have some programs i need to run in 64 bit. Can i switch between the two or have 2 versions of wine?? – michael Feb 24 '15 at 23:58
  • After installation with winetricks, try running ADE from the dash. – ajn Feb 25 '15 at 0:45
1

It appears that after installing winetricks, opening a file with ADE is an option in firefox. It has fixed itself ie thank you ajn. The question, which could remain open until someone else is desperate as i can work now,is what actually happened? Behind the scenes im guessing that file associations have aligned themselves by installing winetricks (??)

I have no need for ADE independently and am happy for it to work as a psuedo plugin, it functions much like acrobat reader.

Im a newbie, what sort of tutorial or topic should i look into to understand this. Please dont waste time if other users could do with your help im ok for now :)

0

Take into account that not all applications work out of the box with Wine. You must make specific tweaks. You have to manually configure Wine to use certain Windows DLL. First check the Wine application Database "appDB" to see if such software is supported already.

Wine tricks is just one of many tools to make such tweaks. Q4wine is an advanced gui tool. Install Crossover for proprietary support. Bordeaux is another gui config manager that supports the install of 3rd party utils and use of custom configs.

To support 64-bit you must atleast install GCC version 4.4

Also you might have to install specific virtual device drivers for application of choice to function.

0

I have successfully installed Adobe Digital Editions 4.5.6 with PlayOnLinux available through Ubuntu Software "store".

But first install winbind (PlayOnLinux will tell you this).

sudo apt-get update
sudo apt-get install winbind

Afterwards just follow PlayOnLinux advice; it will install all the other necessary files for you.

  • I installed PlayOnLinux and then Adobe Digital Editions and ADE wouldn't start - it just crashed and gave an error message. – Geoffrey Wheeler Oct 23 '17 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.